aboutsummaryrefslogtreecommitdiffstats
path: root/meta-n450
diff options
context:
space:
mode:
Diffstat (limited to 'meta-n450')
-rw-r--r--meta-n450/COPYING.MIT17
-rw-r--r--meta-n450/ReleaseNotes103
-rw-r--r--meta-n450/conf/layer.conf10
-rw-r--r--meta-n450/conf/machine/n450.conf13
-rw-r--r--meta-n450/docs/blacksand.pdfbin0 -> 1415280 bytes
-rw-r--r--meta-n450/recipes-bsp/audiofix/audiofix.bb17
-rw-r--r--meta-n450/recipes-bsp/audiofix/files/n450_audiofix13
-rw-r--r--meta-n450/recipes-kernel/linux/linux-wrs_git.bbappend7
8 files changed, 180 insertions, 0 deletions
diff --git a/meta-n450/COPYING.MIT b/meta-n450/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-n450/COPYING.MIT
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/meta-n450/ReleaseNotes b/meta-n450/ReleaseNotes
new file mode 100644
index 00000000..23ac8153
--- /dev/null
+++ b/meta-n450/ReleaseNotes
@@ -0,0 +1,103 @@
+Poky Laverne Release 4.0
+
+- Features and Updates
+- Known Issues
+
+
+FEATURES AND UPDATES
+====================
+
+- Poky Build System Updates
+ * Saved State / Checksumming
+ * Working prebuilt packages
+ * If a cache of prebuilt packages is present, these should be
+ used to accelerate the build
+ * Task based prebuilts
+ * Meta Directory Update
+ * Debug symbols into sysroot
+ * Builds outside Poky TMPDIR
+ * Can install to a readonly directory
+ * Ability to Build GPL v2 only target images
+ * Swapper integrated to detect host contamination
+- Prelink Tool Integration
+ * Integration of cross prelink tools into Poky
+- Toolchain Update
+ * GCC 4.5.0 now default compiler
+ * EGLIBC is default libc provider
+- New and Updated Recipes
+ * Major update of core recipes
+ * Add additional packages to get initial lsb support
+ * Add QT4 Libraries and demo code
+- Packaging
+ * rootfs creating done with RPM
+ * Use pseudo for setting ownership and permissions
+ * Software package Management now use RPM5 and Zypper
+- Standalone Yocto Linux SDK Generator
+ * Enable other SW development
+ * Output from Poky
+ * Cof a sysroot representing a target system
+ * Includes a standalone cross compiler and cross build tools to isolate the two systems
+- Yocto Linux SDK Generator IDE Plug-ins
+ * Work within IDE using Yocto sysroot environment and cross platform toolchains
+ * Remote user spacke tool suite interaction
+ * Eclipse
+ * Anjuta
+- Yocto Linux SDK Generator remote agent
+ * Runs on a "device"
+ * Manage tasks e.g. deployment, launching remote tools, setup cross debugging session
+- Yocto Linux SDK Generator remote tasks support
+ * Remote deploy support
+ * Remote debug suppport
+ * Remote tools interaction
+- Qemu basic system simulation/emulation
+ * Enhanced with GL passthrough
+ * Support user mode NFS
+- User space tool suite for target device tuning, analyzing and optimizing
+ * OProfile
+ * Powertop
+ * Latencytop
+ * Perf
+ * ftrace/lttng user space
+- Host side clients for tools on target devices and IDE interaction
+ * ProfileUI
+ * Lttv-viewer
+- Updated Documentation
+ * Core Reference Manunal Updated
+ * BSP standard document
+ * Quick Start Guide
+ * FAQs
+
+
+KNOWN ISSUES
+============
+
+See bugzilla.yoctoproject.org
+
+382 - oprofile-server on PPC is built big-endian while oprofile-viewer
+ on host system may built with little-endian, but oprofile-server
+ and oprofile-viewer are not implemented to correctly handle
+ conversion between host byte order and network byte order, so
+ oprofile-server and oprofile-viewer may run into connection issue.
+
+439 - No audio from the Blacksand board Front Channel auido jack.
+ Workaround: run the following cmd: 'amixer sset "Front" 30 on'
+
+467 - Issues building with Fedora 14, this distribution provided a version
+ of make that is not compatible with the Poky build system, the
+ workaround it to build a native version of make via the build system.
+ Users of Fedora 14 will need to do a 'bitbake make-native' before
+ running any other targets.
+
+429 - Building poky from scratch with /opt/poky in your path cause host
+ contamination issues, be sure that /opt/poky is not in your path
+ if building from scratch
+
+160 - The Emenlow Hardware gets stuck in the HW Reboot sequence and needs
+ to be power cycled.
+
+Zypper / RPM Issues
+489/490/491 - Due to some archetectual difference between Zypper and RPM5.0,
+ there are some compatibility issues that prevent zypper from
+ working correctly.
+ Packages can still be managed with the rpm commands.
+
diff --git a/meta-n450/conf/layer.conf b/meta-n450/conf/layer.conf
new file mode 100644
index 00000000..f9cc7fe0
--- /dev/null
+++ b/meta-n450/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}:${LAYERDIR}"
+
+# We have a packages directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "n450"
+BBFILE_PATTERN_n450 = "^${LAYERDIR}/"
+BBFILE_PRIORITY_n450 = "6"
diff --git a/meta-n450/conf/machine/n450.conf b/meta-n450/conf/machine/n450.conf
new file mode 100644
index 00000000..eda91d9d
--- /dev/null
+++ b/meta-n450/conf/machine/n450.conf
@@ -0,0 +1,13 @@
+#@TYPE: Machine
+#@NAME: n450
+
+#@DESCRIPTION: Machine configuration for Intel 1-N450 based systems
+
+require conf/machine/atom-pc.conf
+
+SYSLINUX_OPTS = "serial 0 115200"
+SERIAL_CONSOLE = "115200 ttyS0"
+APPEND += "console=ttyS0,115200 console=tty0"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto-stable"
+
diff --git a/meta-n450/docs/blacksand.pdf b/meta-n450/docs/blacksand.pdf
new file mode 100644
index 00000000..971e6df2
--- /dev/null
+++ b/meta-n450/docs/blacksand.pdf
Binary files differ
diff --git a/meta-n450/recipes-bsp/audiofix/audiofix.bb b/meta-n450/recipes-bsp/audiofix/audiofix.bb
new file mode 100644
index 00000000..846d59ee
--- /dev/null
+++ b/meta-n450/recipes-bsp/audiofix/audiofix.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Provide a basic init script to enable audio"
+DESCRIPTION = "This package provides an init script which enables the audio on startup via the amixer command. It address a problem with the development board that has the audio muted on power on."
+SECTION = "base"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r2"
+RDEPENDS = "amixer"
+
+SRC_URI = "file://n450_audiofix"
+
+do_install () {
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/rc5.d
+ install -m 0755 ${WORKDIR}/n450_audiofix ${D}${sysconfdir}/init.d
+ ln -sf ../init.d/n450_audiofix ${D}/sysconfdir/rc5.d/S91n450_audiofix
+}
diff --git a/meta-n450/recipes-bsp/audiofix/files/n450_audiofix b/meta-n450/recipes-bsp/audiofix/files/n450_audiofix
new file mode 100644
index 00000000..9ec04482
--- /dev/null
+++ b/meta-n450/recipes-bsp/audiofix/files/n450_audiofix
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+AMIXER=`which amixer`
+
+if [ ! -e $AMIXER ]; then
+ if [ -e /usr/bin/amixer ]; then
+ AMIXER=/usr/bin/amixer
+ else
+ echo "No amixer, so unable to reset Front channel ON"
+ fi
+fi
+
+
diff --git a/meta-n450/recipes-kernel/linux/linux-wrs_git.bbappend b/meta-n450/recipes-kernel/linux/linux-wrs_git.bbappend
new file mode 100644
index 00000000..3a893f64
--- /dev/null
+++ b/meta-n450/recipes-kernel/linux/linux-wrs_git.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+WRMACHINE_n450 = "atom-pc"
+COMPATIBLE_MACHINE_n450 = "n450"
+
+SRCREV="${AUTOREV}"
+# Functionality flags
+#KERNEL_REVISION_CHECKING ?= "t"