aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch24
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest8
2 files changed, 32 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch
new file mode 100644
index 00000000..74c260ab
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch
@@ -0,0 +1,24 @@
+From 34f3eb50ad5063bbf00ade1e9281e3c238d3216e Mon Sep 17 00:00:00 2001
+From: Chin Huat Ang <chin.huat.ang@intel.com>
+Date: Wed, 16 Oct 2019 13:06:26 +0800
+Subject: [PATCH] mock_engine: install to CMAKE_INSTALL_LIBDIR
+
+Upstream-Status: Pending
+Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com>
+---
+ inference-engine/tests/mock_engine/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/inference-engine/tests/mock_engine/CMakeLists.txt b/inference-engine/tests/mock_engine/CMakeLists.txt
+index a0f77cf..753c901 100644
+--- a/inference-engine/tests/mock_engine/CMakeLists.txt
++++ b/inference-engine/tests/mock_engine/CMakeLists.txt
+@@ -38,3 +38,5 @@ target_compile_definitions(${TARGET_NAME} PRIVATE IMPLEMENT_INFERENCE_ENGINE_API
+ set_property(TARGET ${TARGET_NAME} PROPERTY CXX_STANDARD 11)
+ set_property(TARGET ${TARGET_NAME} PROPERTY CXX_STANDARD_REQUIRED ON)
+ set_property(TARGET ${TARGET_NAME} PROPERTY COMPILE_PDB_NAME ${TARGET_NAME})
++
++install(TARGETS ${TARGET_NAME} EXPORT ${TARGET_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+--
+2.7.4
+
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest
index 77310f9f..92f238a9 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest
@@ -1,5 +1,13 @@
#!/bin/sh
+# InferenceEngineUnitTests requires libmock_engine.so, since they are
+# installed in the same directory we will need to set LD_LIBRARY_PATH
+# so that libmock_engine.so is picked up correctly. We also assume that
+# this script is only execute within the same directory where it is
+# installed.
+
+export LD_LIBRARY_PATH=.
+
./InferenceEngineUnitTests |sed \
-e 's|\[.*OK.*\]\(.*\)|PASS:\1|' \
-e 's|\[.*FAILED.*\]\(.*\)|FAIL:\1|'