aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb
new file mode 100644
index 00000000..33847ad4
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "OpenVINO Model Optimzer"
+DESCRIPTION = "Model Optimizer is a cross-platform command-line tool that \
+facilitates the transition between the training and deployment \
+environment, performs static model analysis, and adjusts deep \
+learning models for optimal execution on end-point target devices."
+HOMEPAGE = "https://01.org/openvinotoolkit"
+
+SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
+ "
+SRCREV = "fe3f978b98c86eaeed3cbdc280e1ffd0bc50d278"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ mkdir -p ${D}${datadir}/openvino/model-optimizer
+ cp -r model-optimizer ${D}${datadir}/openvino/
+}
+
+RDEPENDS_${PN} += " \
+ python3-numpy \
+ python3-protobuf \
+ python3-defusedxml \
+ python3-networkx \
+ python3-test-generator \
+ bash \
+ "
+
+FILES_${PN} += "${datadir}/openvino"