aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb)6
1 files changed, 4 insertions, 2 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
index 6599c9b6..c45c36d8 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
@@ -9,12 +9,12 @@ SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=h
file://point-to-correct-llvm-tblgen.patch \
"
-SRCREV = "daf5e4dd718477ae8cf89a283c653939d9182f15"
+SRCREV = "94af090661d7c953c516c97a25ed053c744a0737"
S = "${WORKDIR}/git"
inherit cmake
-DEPENDS += "clang clang-native"
+DEPENDS += "clang"
DEPENDS_append_class-target = " opencl-clang-native"
LDFLAGS_append_class-native = " -fuse-ld=lld"
@@ -33,3 +33,5 @@ do_install_append_class-native() {
}
BBCLASSEXTEND = "native nativesdk"
+
+TOOLCHAIN_class-native = "clang"