aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch11
1 files changed, 8 insertions, 3 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
index b0bfa6ee..417e0221 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
@@ -1,4 +1,4 @@
-From 40be69a2c9460aea40beab8734684050988b9322 Mon Sep 17 00:00:00 2001
+From 2ce2619b544678541e0cc56494e2927086718613 Mon Sep 17 00:00:00 2001
From: Anuj Mittal <anuj.mittal@intel.com>
Date: Tue, 26 Mar 2019 14:11:29 +0800
Subject: [PATCH] point to correct llvm-tblgen
@@ -10,12 +10,14 @@ git through cmake.
Upstream-Status: Inappropriate [OE specific]
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
---
CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 174133b..be409e5 100644
+index 1371a67..f83ffcc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,7 +53,7 @@ endif(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
@@ -27,7 +29,7 @@ index 174133b..be409e5 100644
if (NOT WIN32)
add_subdirectory( linux_linker )
-@@ -102,7 +102,7 @@ endif(NOT USE_PREBUILT_LLVM)
+@@ -138,7 +138,7 @@ endif(NOT USE_PREBUILT_LLVM)
set (COMPILE_OPTIONS_TD opencl_clang_options.td)
set (COMPILE_OPTIONS_INC opencl_clang_options.inc)
@@ -36,3 +38,6 @@ index 174133b..be409e5 100644
set(LLVM_TARGET_DEFINITIONS ${COMPILE_OPTIONS_TD})
if(USE_PREBUILT_LLVM)
set(TABLEGEN_ADDITIONAL -I ${LLVM_INCLUDE_DIRS})
+--
+2.17.1
+