aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/libva/libva-intel-driver_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-multimedia/libva/libva-intel-driver_1.4.1.bb')
-rw-r--r--common/recipes-multimedia/libva/libva-intel-driver_1.4.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/common/recipes-multimedia/libva/libva-intel-driver_1.4.1.bb b/common/recipes-multimedia/libva/libva-intel-driver_1.4.1.bb
new file mode 100644
index 00000000..1a04ef48
--- /dev/null
+++ b/common/recipes-multimedia/libva/libva-intel-driver_1.4.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "VA driver for Intel G45 & HD Graphics family"
+DESCRIPTION = "libva-driver-intel is the VA-API implementation \
+for Intel G45 chipsets and Intel HD Graphics for Intel Core \
+processor family."
+
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/vaapi"
+BUGTRACKER = "https://bugs.freedesktop.org"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
+
+COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+
+DEPENDS = "libva libdrm"
+
+SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/${BPN}/${BPN}-${PV}.tar.bz2"
+SRC_URI += "file://wayland-include.patch"
+
+SRC_URI[md5sum] = "688d5f4d7884b15e70205d528c1d61da"
+SRC_URI[sha256sum] = "fe6784c7ba6092204e3e7d4142e6023386b43f08127dae1243385078c5c21fec"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= "${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
+ ${@base_contains("DISTRO_FEATURES", "opengl wayland", "wayland", "", d)}"
+PACKAGECONFIG[x11] = "--enable-x11,--disable-x11"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland virtual/egl"
+
+FILES_${PN} += "${libdir}/dri/*.so"
+FILES_${PN}-dev += "${libdir}/dri/*.la"
+FILES_${PN}-dbg += "${libdir}/dri/.debug"