summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/gummiboot/gummiboot_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/gummiboot/gummiboot_git.bb')
-rw-r--r--common/recipes-bsp/gummiboot/gummiboot_git.bb18
1 files changed, 6 insertions, 12 deletions
diff --git a/common/recipes-bsp/gummiboot/gummiboot_git.bb b/common/recipes-bsp/gummiboot/gummiboot_git.bb
index 871a9500..ff088a8c 100644
--- a/common/recipes-bsp/gummiboot/gummiboot_git.bb
+++ b/common/recipes-bsp/gummiboot/gummiboot_git.bb
@@ -9,22 +9,16 @@ DEPENDS = "gnu-efi util-linux"
inherit autotools
inherit deploy
-PV = "33"
+PV = "35+git${SRCPV}"
PR = "r0"
-SRCREV = "cbc63ae9d6161fe6412f0457e72a276f5acb6e2a"
-SRC_URI = "git://anongit.freedesktop.org/gummiboot \
- file://0001-configure.ac-Add-option-to-disable-configuring-the-B.patch \
- file://0002-configure.ac-Use-AC_CHECK_HEADER-to-detect-the-efi-i.patch \
- file://0003-Makefile.am-Allow-for-user-override-of-EFI-include-d.patch \
- file://0004-configure.ac-Allow-for-more-than-just-i686-for-ia32.patch \
- file://0005-Auto-detect-both-x64-and-ia32-boot-.efi-payloads.patch \
- file://0006-Add-32-bit-compatible-rdtsc-asm.patch"
+SRCREV = "6feb7d971f79e88ed395637390d58404fba5f3c3"
+SRC_URI = "git://anongit.freedesktop.org/gummiboot"
S = "${WORKDIR}/git"
-EXTRA_OECONF = "--disable-biostest"
-EXTRA_OEMAKE = "INCDIR=${STAGING_INCDIR} GNUEFI_LDS_DIR=${STAGING_LIBDIR} \
- GNUEFI_LIBS='-L ${STAGING_LIBDIR}'"
+EXTRA_OECONF = "--disable-biostest --with-efi-includedir=${STAGING_INCDIR} \
+ --with-efi-ldsdir=${STAGING_LIBDIR} \
+ --with-efi-libdir=${STAGING_LIBDIR}"
do_deploy () {
install ${S}/gummiboot*.efi ${DEPLOYDIR}/