aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.1.bb
index c788c53b..b9767517 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.1.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.1.bb
@@ -81,6 +81,10 @@ do_install_append() {
install -D -m0644 ${S}/thirdparty/movidius/mvnc/src/97-myriad-usbboot.rules ${D}${sysconfdir}/udev/rules.d/97-myriad-usbboot.rules
fi
+
+ if ${@bb.utils.contains('PACKAGECONFIG', 'opencl', 'true', 'false', d)}; then
+ cp -r ${S}/src/cldnn_engine/cldnn_global_custom_kernels ${D}${libdir}/
+ fi
}
do_install_ptest_base_prepend() {
@@ -103,6 +107,7 @@ FILES_${PN}-dev = "${includedir} \
FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
${datadir}/openvino \
+ ${libdir}/cldnn_global_custom_kernels \
"
# Move inference engine samples into a separate package