aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/ace/ace_6.5.3.bb1
-rw-r--r--recipes-bsp/ace/files/config_linux.patch30
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/ace/ace_6.5.3.bb b/recipes-bsp/ace/ace_6.5.3.bb
index a75471e1..f1a10eea 100644
--- a/recipes-bsp/ace/ace_6.5.3.bb
+++ b/recipes-bsp/ace/ace_6.5.3.bb
@@ -9,6 +9,7 @@ DEPENDS += "openssl gperf-native"
SRC_URI = "ftp://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 \
file://ace_config.patch \
+ file://config_linux.patch \
"
SRC_URI[md5sum] = "4cc5f109ebd17cd56f0539d1b47d16b3"
diff --git a/recipes-bsp/ace/files/config_linux.patch b/recipes-bsp/ace/files/config_linux.patch
new file mode 100644
index 00000000..323a63eb
--- /dev/null
+++ b/recipes-bsp/ace/files/config_linux.patch
@@ -0,0 +1,30 @@
+config-linux.h: fix glibc build failure
+
+Recent glibc v2.30 dropped XSI STREAMS declarations,
+which causing below build failure.
+
+poky/build/tmp/work/corei7-64-poky-linux/ace/6.5.3-r0/ACE_wrappers/ace/os_include/os_stropts.h:56:17: fatal error: stropts.h: No such file or directory
+| 56 | # include /**/ <stropts.h>
+| | ^~~~~~~~~~~
+| compilation terminated.
+
+Added GLIBC checks for affected versions.
+
+For more information about glibc v2.30 change, please check:
+https://sourceware.org/git/?p=glibc.git;a=commit;h=a0a0dc83173ce11ff45105fd32e5d14356cdfb9c
+
+Upstream-Status: Submitted [https://github.com/DOCGroup/ACE_TAO/pull/939]
+
+Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
+
+--- ACE_wrappers_original/ace/config-linux.h 2018-11-19 17:45:53.163139000 +0800
++++ ACE_wrappers/ace/config-linux.h 2019-08-13 17:04:17.620866464 +0800
+@@ -295,7 +295,7 @@
+
+ // Starting with FC9 rawhide this file is not available anymore but
+ // this define is set
+-#if defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1
++#if (defined(__GLIBC__) && (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 30)) || (defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1)
+ # define ACE_LACKS_STROPTS_H
+ # define ACE_LACKS_STRRECVFD
+ #endif