aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
index 6fd64d27..4fe5d874 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
@@ -5,6 +5,9 @@ deep learning models through a high-level C++ Inference Engine API \
integrated with application logic."
SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
+ https://download.01.org/opencv/2019/openvinotoolkit/R3/inference_engine/firmware_ma2450_784.zip;name=ma2450 \
+ https://download.01.org/opencv/2019/openvinotoolkit/R3/inference_engine/firmware_ma2x8x_784.zip;name=ma2x8x \
+ https://download.01.org/opencv/2019/openvinotoolkit/R3/inference_engine/firmware_mv0262_784.zip;name=mv0262 \
file://0001-R2-Build-fixes.patch;patchdir=../ \
file://0002-R2-Install-DLDT-headers-libs-sample-Apps.patch;patchdir=../ \
file://0003-use-GNUInstallDirs-on-nix.patch;patchdir=../ \
@@ -16,6 +19,15 @@ SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
"
SRCREV = "1c794d971cdd3c94de5ea4a6c9588eac63f4cc57"
+SRC_URI[ma2450.md5sum] = "29198491965f2d3da489aea3b2d5fbca"
+SRC_URI[ma2450.sha256sum] = "b74c314bf88121536d07cd0e288cdac0e72b42d5aa81b23b7b5c1858ef03539b"
+
+SRC_URI[ma2x8x.md5sum] = "bf1b85caa637566e61922c59afcb7c40"
+SRC_URI[ma2x8x.sha256sum] = "2993ecfb638b311dca0f208bec8bf66ba896274c513d949781b9f98383dac652"
+
+SRC_URI[mv0262.md5sum] = "026f30b5b60ccadf7aedc3ebe0fbf7f1"
+SRC_URI[mv0262.sha256sum] = "3f55645ac3a0d35467d0ebb8689852664d65b73735ad5d782d423468d6e12781"
+
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
@@ -24,7 +36,6 @@ inherit cmake ptest python3native
S = "${WORKDIR}/git/inference-engine"
EXTRA_OECMAKE += " \
- -DENABLE_VPU=OFF \
-DENABLE_OPENCV=0 \
-DENABLE_SAMPLES_CORE=1 \
-DENABLE_PLUGIN_RPATH=0 \
@@ -55,6 +66,13 @@ COMPATIBLE_HOST_libc-musl = "null"
PACKAGECONFIG ?= ""
PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1 -DCLDNN__IOCL_ICD_INCDIRS=${STAGING_INCDIR} -DCLDNN__IOCL_ICD_STLDIRS=${STAGING_LIBDIR} -DCLDNN__IOCL_ICD_SHLDIRS=${STAGING_LIBDIR}, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime"
PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3"
+PACKAGECONFIG[vpu] = "-DVPU_FIRMWARE_MA2450_FILE=../mvnc/MvNCAPI-ma2450.mvcmd -DVPU_FIRMWARE_MA2X8X_FILE=../mvnc/MvNCAPI-ma2x8x.mvcmd -DVPU_FIRMWARE_MV0262_FILE=../mvnc/MvNCAPI-mv0262.mvcmd,-DENABLE_VPU=OFF,,${PN}-vpu-firmware"
+
+do_install_append() {
+ install -m0644 ${WORKDIR}/mvnc/MvNCAPI-ma2450.mvcmd ${D}${libdir}
+ install -m0644 ${WORKDIR}/mvnc/MvNCAPI-ma2x8x.mvcmd ${D}${libdir}
+ install -m0644 ${WORKDIR}/mvnc/MvNCAPI-mv0262.mvcmd ${D}${libdir}
+}
do_install_ptest_base_prepend() {
# While not a Makefile based project that strictly falls into the category of
@@ -79,9 +97,10 @@ FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
"
# Move inference engine samples into a separate package
-PACKAGES =+ "${PN}-samples"
+PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware"
FILES_${PN}-samples = "${bindir}"
+FILES_${PN}-vpu-firmware += "${libdir}/*.mvcmd"
# Package for inference engine python API
PACKAGES =+ "${PN}-${PYTHON_PN}"