summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/cryptodev/cryptodev-module/0001-zc-Force-4.10-get_user_pages_remote-API.patch26
-rw-r--r--recipes-kernel/cryptodev/cryptodev-module_%.bbappend9
-rw-r--r--recipes-kernel/iwlwifi/backport-iwlwifi/0001-hrtimer-fix-version-numbers-because-production-kerne.patch87
-rw-r--r--recipes-kernel/iwlwifi/backport-iwlwifi_git.bb4
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.9.bb20
-rw-r--r--recipes-kernel/linux/linux-intel_4.9.bb20
-rw-r--r--recipes-kernel/lttng/lttng-modules/0002-lttng-modules-PKT-4.9-yocto-build-failed.patch38
-rw-r--r--recipes-kernel/lttng/lttng-modules_%.bbappend7
8 files changed, 0 insertions, 211 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-module/0001-zc-Force-4.10-get_user_pages_remote-API.patch b/recipes-kernel/cryptodev/cryptodev-module/0001-zc-Force-4.10-get_user_pages_remote-API.patch
deleted file mode 100644
index 353126fe..00000000
--- a/recipes-kernel/cryptodev/cryptodev-module/0001-zc-Force-4.10-get_user_pages_remote-API.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3fcc81ad127c267018aed96a359bbf01db1bd8ee Mon Sep 17 00:00:00 2001
-From: Saul Wold <sgw@linux.intel.com>
-Date: Sat, 1 Apr 2017 11:43:31 -0700
-Subject: [PATCH] zc: Force 4.10 get_user_pages_remote API
-
-This change forces the newer API, as the linux-intel 4.9-LTS kernel
-backported the 4.10 API change in the page handling code.
-
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- zc.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/zc.c b/zc.c
-index ae464ff..b2759ce 100644
---- a/zc.c
-+++ b/zc.c
-@@ -65,7 +65,7 @@ int __get_userbuf(uint8_t __user *addr, uint32_t len, int write,
- #elif (LINUX_VERSION_CODE < KERNEL_VERSION(4, 9, 0))
- ret = get_user_pages_remote(task, mm,
- (unsigned long)addr, pgcount, write, 0, pg, NULL);
--#elif (LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0))
-+#elif (LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0) & 0)
- ret = get_user_pages_remote(task, mm,
- (unsigned long)addr, pgcount, write ? FOLL_WRITE : 0,
- pg, NULL);
diff --git a/recipes-kernel/cryptodev/cryptodev-module_%.bbappend b/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
deleted file mode 100644
index c59ddb2f..00000000
--- a/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-python() {
- # When we add more kernels for linux-intel, we may have to add a Version check
- if (d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel"):
- src_uri = d.getVar("SRC_URI")
- d.setVar("SRC_URI", src_uri +
- " file://0001-zc-Force-4.10-get_user_pages_remote-API.patch")
-}
diff --git a/recipes-kernel/iwlwifi/backport-iwlwifi/0001-hrtimer-fix-version-numbers-because-production-kerne.patch b/recipes-kernel/iwlwifi/backport-iwlwifi/0001-hrtimer-fix-version-numbers-because-production-kerne.patch
deleted file mode 100644
index 4fdc36f7..00000000
--- a/recipes-kernel/iwlwifi/backport-iwlwifi/0001-hrtimer-fix-version-numbers-because-production-kerne.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From ecb29b78ce946c802058be0c46a0d20432f412e5 Mon Sep 17 00:00:00 2001
-From: Saul Wold <sgw@linux.intel.com>
-Date: Thu, 28 Sep 2017 10:51:15 -0700
-Subject: [PATCH] hrtimer: fix version numbers because production kernel has
- update
-
-Decrease the version check because the OTC production kernel which is
-4.9 includes the HRTimer code that this is using.
-
-Upstream-Status: [Backport] It's been backported into the older kernel
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- backport-include/linux/hrtimer.h | 2 +-
- drivers/net/wireless/intel/iwlwifi/mvm/tx.c | 2 +-
- drivers/net/wireless/intel/iwlwifi/pcie/tx.c | 2 +-
- drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c | 2 +-
- net/mac80211/tx.c | 2 +-
- 5 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/backport-include/linux/hrtimer.h b/backport-include/linux/hrtimer.h
-index bdcf106e1..ae128852d 100644
---- a/backport-include/linux/hrtimer.h
-+++ b/backport-include/linux/hrtimer.h
-@@ -4,7 +4,7 @@
- #include_next <linux/hrtimer.h>
- #include <linux/interrupt.h>
-
--#if LINUX_VERSION_IS_LESS(4,10,0)
-+#if LINUX_VERSION_IS_LESS(4,9,0)
- static inline void backport_hrtimer_start(struct hrtimer *timer, s64 time,
- const enum hrtimer_mode mode)
- {
-diff --git a/drivers/net/wireless/intel/iwlwifi/mvm/tx.c b/drivers/net/wireless/intel/iwlwifi/mvm/tx.c
-index cf1f95a01..e6f1ff294 100644
---- a/drivers/net/wireless/intel/iwlwifi/mvm/tx.c
-+++ b/drivers/net/wireless/intel/iwlwifi/mvm/tx.c
-@@ -1310,7 +1310,7 @@ static void iwl_mvm_tx_lat_add_ts_ack(struct sk_buff *skb)
- s64 ts_1 = ktime_to_ns(skb->tstamp) >> 32;
- s64 diff = temp - ts_1;
-
--#if LINUX_VERSION_IS_LESS(4,10,0)
-+#if LINUX_VERSION_IS_LESS(4,9,0)
- skb->tstamp.tv64 += diff;
- #else
- skb->tstamp += diff;
-diff --git a/drivers/net/wireless/intel/iwlwifi/pcie/tx.c b/drivers/net/wireless/intel/iwlwifi/pcie/tx.c
-index df81bce25..ad664bacd 100644
---- a/drivers/net/wireless/intel/iwlwifi/pcie/tx.c
-+++ b/drivers/net/wireless/intel/iwlwifi/pcie/tx.c
-@@ -1955,7 +1955,7 @@ static void iwl_trans_pci_tx_lat_add_ts_write(struct sk_buff *skb)
- s64 ts_1 = ktime_to_ns(skb->tstamp) >> 32;
- s64 diff = temp - ts_1;
-
--#if LINUX_VERSION_IS_LESS(4,10,0)
-+#if LINUX_VERSION_IS_LESS(4,9,0)
- skb->tstamp.tv64 += diff << 16;
- #else
- skb->tstamp += diff << 16;
-diff --git a/drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c b/drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c
-index e4d45bcf7..cdd0ba9a2 100644
---- a/drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c
-+++ b/drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c
-@@ -796,7 +796,7 @@ void iwl_slv_tx_lat_add_ts_write(struct iwl_trans_slv *trans_slv,
-
- ts_1 = ktime_to_ns(data_entry->skb->tstamp) >> 32;
- diff = temp - ts_1;
--#if LINUX_VERSION_IS_LESS(4,10,0)
-+#if LINUX_VERSION_IS_LESS(4,9,0)
- data_entry->skb->tstamp.tv64 += diff << 16;
- #else
- data_entry->skb->tstamp += diff << 16;
-diff --git a/net/mac80211/tx.c b/net/mac80211/tx.c
-index 94a348688..0f226c413 100644
---- a/net/mac80211/tx.c
-+++ b/net/mac80211/tx.c
-@@ -2278,7 +2278,7 @@ static void ieee80211_tx_latency_start_msrmnt(struct ieee80211_local *local,
- if (!tx_latency && !tx_consec && !tx_thrshld)
- return;
- temp = ktime_to_ms(ktime_get());
--#if LINUX_VERSION_IS_LESS(4,10,0)
-+#if LINUX_VERSION_IS_LESS(4,9,0)
- skb->tstamp.tv64 += temp << 32;
- #else
- skb->tstamp += temp << 32;
---
-2.13.5
-
diff --git a/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb b/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb
index 1453f519..71837318 100644
--- a/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb
+++ b/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb
@@ -20,13 +20,9 @@ inherit module
PV = "30"
SRCREV = "b31221a99488021300e7f89d2ecf9bdd2bc52dd2"
-# Add a patch for Intel's Production Kernel as it's got a backport of HRTimers
-PK_PATCH = "${@bb.utils.contains('PREFERRED_PROVIDER_virtual/kernel','linux-intel','file://0001-hrtimer-fix-version-numbers-because-production-kerne.patch','',d)}"
-
SRC_URI = " \
git://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi;branch=release/LinuxCore${PV} \
file://0001-Makefile.real-skip-host-install-scripts.patch \
- ${PK_PATCH} \
file://iwlwifi.conf \
"
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb
deleted file mode 100644
index 0b81987a..00000000
--- a/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-
-require linux-intel.inc
-
-# Skip processing of this recipe if it is not explicitly specified as the
-# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
-# to build multiple virtual/kernel providers, e.g. as dependency of
-# core-image-rt-sdk, core-image-rt.
-python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
- raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
-}
-
-KBRANCH = "4.9/yocto/base-rt"
-KMETA_BRANCH = "yocto-4.9"
-
-LINUX_VERSION ?= "4.9.84"
-SRCREV_machine ?= "33b17c3a62dc470c849f85ce2a90cfa90e96bcf5"
-SRCREV_meta ?= "bae5cc4e973f60baa35ed227ba0c3bdda4d16e87"
-
-LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel_4.9.bb b/recipes-kernel/linux/linux-intel_4.9.bb
deleted file mode 100644
index 687c6be8..00000000
--- a/recipes-kernel/linux/linux-intel_4.9.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-
-require linux-intel.inc
-
-KBRANCH = "4.9/yocto/base"
-KMETA_BRANCH = "yocto-4.9"
-
-SRC_URI_append = " \
- file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \
- "
-
-LINUX_VERSION ?= "4.9.146"
-SRCREV_machine ?= "0411ffc9047ee2b127991663660d2514ba451ef3"
-SRCREV_meta ?= "f9e90afd4e47920e990dacb73cd6508917ca5422"
-
-# For Crystalforest and Romley
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
-
-# Functionality flags
-KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
diff --git a/recipes-kernel/lttng/lttng-modules/0002-lttng-modules-PKT-4.9-yocto-build-failed.patch b/recipes-kernel/lttng/lttng-modules/0002-lttng-modules-PKT-4.9-yocto-build-failed.patch
deleted file mode 100644
index 32b49b8d..00000000
--- a/recipes-kernel/lttng/lttng-modules/0002-lttng-modules-PKT-4.9-yocto-build-failed.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From ebfdc8b8af17f9cf23c6878eb52476fde7b48e5c Mon Sep 17 00:00:00 2001
-From: Priyalee Kushwaha <priyalee.kushwaha@intel.com>
-Date: Fri, 22 Sep 2017 14:40:57 -0700
-Subject: [PATCH] lttng-modules: PKT 4.9 yocto build failed
-
-PKT 4.9 yocto kernel backports a patch from upstream and that
-changes header include/linux/ktimer.h. Since this backported
-patch is only relevant for PKT kernel, we need to carry this
-patch.
-
-Upstream-Status: Backport
-Signed-off-by: Kushwaha, Priyalee <priyalee.kushwaha@intel.com>
----
- instrumentation/events/lttng-module/timer.h | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/instrumentation/events/lttng-module/timer.h b/instrumentation/events/lttng-module/timer.h
-index d62fd25..59da988 100644
---- a/instrumentation/events/lttng-module/timer.h
-+++ b/instrumentation/events/lttng-module/timer.h
-@@ -16,11 +16,11 @@ struct timer_list;
-
- #endif /* _TRACE_TIMER_DEF_ */
-
--#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0))
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0))
- #define lttng_ktime_get_tv64(kt) (kt)
--#else /* #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0)) */
-+#else /* #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)) */
- #define lttng_ktime_get_tv64(kt) ((kt).tv64)
--#endif /* #else #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0)) */
-+#endif /* #else #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)) */
-
- LTTNG_TRACEPOINT_EVENT_CLASS(timer_class,
-
---
-2.7.4
-
diff --git a/recipes-kernel/lttng/lttng-modules_%.bbappend b/recipes-kernel/lttng/lttng-modules_%.bbappend
deleted file mode 100644
index dc1c4a74..00000000
--- a/recipes-kernel/lttng/lttng-modules_%.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-
-LTTNG_PATCH = "${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/kernel','linux-intel linux-intel-rt','file://0002-lttng-modules-PKT-4.9-yocto-build-failed.patch','',d)}"
-
-SRC_URI_append_intel-x86-common = " ${LTTNG_PATCH}"
-