summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch31
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot_%.bbappend15
2 files changed, 0 insertions, 46 deletions
diff --git a/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch b/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch
deleted file mode 100644
index 8d0b6149..00000000
--- a/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 58669ad764767afea4de53f8a97357773b1855ef Mon Sep 17 00:00:00 2001
-From: Saul Wold <sgw@linux.intel.com>
-Date: Tue, 25 Oct 2016 12:54:08 -0700
-Subject: [PATCH] efi/boot.c: workaround for Joule BIOS hang
-
-This patch should be removed when the BIOS is fixed
-
-Authored-by: Steve Sakoman <steve@sakoman.com>
-
-Upstream-Status: Inappropriate [machine specific workaround]
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- src/boot/efi/boot.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/boot/efi/boot.c b/src/boot/efi/boot.c
-index 3dcd9a5..3c6ed8c 100644
---- a/src/boot/efi/boot.c
-+++ b/src/boot/efi/boot.c
-@@ -649,7 +649,7 @@ static BOOLEAN menu_run(Config *config, ConfigEntry **chosen_entry, CHAR16 *load
- }
-
- /* timeout disabled, wait for next key */
-- wait = TRUE;
-+ wait = FALSE;
- continue;
- }
-
---
-2.7.4
-
diff --git a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
deleted file mode 100644
index d46ef410..00000000
--- a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:"
-
-SRC_URI_append_intel-x86-common = " \
- file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \
- "
-
-PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
-
-do_compile_append_intel-x86-common() {
- ninja src/boot/efi/linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
-}
-
-do_deploy_append_intel-x86-common() {
- install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR}
-}