aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README2
-rw-r--r--recipes-core/microcode/intel-microcode_20191115.bb (renamed from recipes-core/microcode/intel-microcode_20190618.bb)14
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.14.bb8
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.19.bb8
-rw-r--r--recipes-kernel/linux/linux-intel_4.14.bb6
-rw-r--r--recipes-kernel/linux/linux-intel_4.19.bb4
6 files changed, 22 insertions, 20 deletions
diff --git a/README b/README
index 85d4fedf..71a34de8 100644
--- a/README
+++ b/README
@@ -390,7 +390,7 @@ V. Guidelines for submitting patches
====================================
Please submit any patches against meta-intel BSPs to the meta-intel
-mailing list (meta-intel@yoctoproject.org). Also, if your patches are
+mailing list (meta-intel@lists.yoctoproject.org). Also, if your patches are
available via a public git repository, please also include a URL to
the repo and branch containing your patches as that makes it easier
for maintainers to grab and test your patches.
diff --git a/recipes-core/microcode/intel-microcode_20190618.bb b/recipes-core/microcode/intel-microcode_20191115.bb
index 65b8036a..f0e542d8 100644
--- a/recipes-core/microcode/intel-microcode_20190618.bb
+++ b/recipes-core/microcode/intel-microcode_20191115.bb
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://license;md5=99b296eb12723fd1eeb52e24971eed84"
SRC_URI = "git://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files.git;protocol=https \
"
-SRCREV = "940d904b7272edd689a5f0eef9dee09c13746748"
+SRCREV = "33b7b2f3817e362111cd91910026ab8907f21710"
DEPENDS = "iucode-tool-native"
S = "${WORKDIR}/git"
@@ -45,10 +45,10 @@ do_compile() {
}
do_install() {
- install -d ${D}${base_libdir}/firmware/intel-ucode/
- install ${WORKDIR}/microcode_${PV}.bin ${D}${base_libdir}/firmware/intel-ucode/
- cd ${D}${base_libdir}/firmware/intel-ucode/
- ln -sf microcode_${PV}.bin microcode.bin
+ install -d ${D}${nonarch_base_libdir}/firmware/intel-ucode/
+ ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
+ --write-firmware=${D}${nonarch_base_libdir}/firmware/intel-ucode \
+ ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/*
}
do_deploy() {
@@ -63,4 +63,6 @@ addtask deploy before do_build after do_compile
PACKAGES = "${PN}"
-FILES_${PN} = "${base_libdir}"
+FILES_${PN} = "${nonarch_base_libdir}"
+
+UPSTREAM_CHECK_GITTAGREGEX = "^microcode-(?P<pver>(\d+)[a-z])$"
diff --git a/recipes-kernel/linux/linux-intel-rt_4.14.bb b/recipes-kernel/linux/linux-intel-rt_4.14.bb
index af5a4e35..83d6201f 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.14.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.14.bb
@@ -5,7 +5,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
@@ -17,8 +17,8 @@ SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.14.139"
-SRCREV_machine ?= "3709d576bddc7bb30411577d769a5eea24e7acf8"
-SRCREV_meta ?= "bc35d5bd224ab031440a69f9806d839db382f05c"
+LINUX_VERSION ?= "4.14.146"
+SRCREV_machine ?= "f8e35039bf37038f1cba7b125e3c4fa49745072b"
+SRCREV_meta ?= "c8f030fdbf6046dede4b7ce6c94b5b24221c250e"
LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel-rt_4.19.bb b/recipes-kernel/linux/linux-intel-rt_4.19.bb
index a7e272ee..a38ac388 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.19.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.19.bb
@@ -5,7 +5,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
@@ -17,8 +17,8 @@ KMETA_BRANCH = "yocto-4.19"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.19.59"
-SRCREV_machine ?= "d6dc301c71aea6098e5e19ef3f265d0ba9981167"
-SRCREV_meta ?= "960be4218436fbbb3500e019f7abf02fa94e6aac"
+LINUX_VERSION ?= "4.19.72"
+SRCREV_machine ?= "cf2e1ceb823576067ce01f02f1750a45c35adae5"
+SRCREV_meta ?= "ad6f8b357720ca8167a090713b7746230cf4b314"
LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel_4.14.bb b/recipes-kernel/linux/linux-intel_4.14.bb
index 6ba63611..9acb75fa 100644
--- a/recipes-kernel/linux/linux-intel_4.14.bb
+++ b/recipes-kernel/linux/linux-intel_4.14.bb
@@ -10,9 +10,9 @@ SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch \
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.14.146"
-SRCREV_machine ?= "c5bbe5b77b21abbb5dcdc6df080c2d7295cf3d90"
-SRCREV_meta ?= "bc35d5bd224ab031440a69f9806d839db382f05c"
+LINUX_VERSION ?= "4.14.152"
+SRCREV_machine ?= "f500fab13d11290921fc16c0e8b08c671819ad43"
+SRCREV_meta ?= "c8f030fdbf6046dede4b7ce6c94b5b24221c250e"
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
diff --git a/recipes-kernel/linux/linux-intel_4.19.bb b/recipes-kernel/linux/linux-intel_4.19.bb
index 7e26cd0f..79727f91 100644
--- a/recipes-kernel/linux/linux-intel_4.19.bb
+++ b/recipes-kernel/linux/linux-intel_4.19.bb
@@ -9,8 +9,8 @@ SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurs
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.19.73"
-SRCREV_machine ?= "ca05e9cd64b5afbd698fa2707be4d2602890b849"
+LINUX_VERSION ?= "4.19.80"
+SRCREV_machine ?= "6570cbed7b20741a3433c3192ed93ac0fea6c554"
SRCREV_meta ?= "a7cb57afb9fb9787079c28a1028d797632105e56"
# For Crystalforest and Romley