aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.14.bb6
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.19.bb8
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.9.bb2
-rw-r--r--recipes-kernel/linux/linux-intel_4.14.bb4
-rw-r--r--recipes-kernel/linux/linux-intel_4.19.bb6
-rw-r--r--recipes-kernel/linux/linux-intel_4.9.bb6
6 files changed, 16 insertions, 16 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.14.bb b/recipes-kernel/linux/linux-intel-rt_4.14.bb
index 0611304c..6967ec25 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.14.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.14.bb
@@ -5,7 +5,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
@@ -17,8 +17,8 @@ SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.14.106"
-SRCREV_machine ?= "5cfa4c85d15168b84e40bd38b7d31a62a01e40d3"
+LINUX_VERSION ?= "4.14.134"
+SRCREV_machine ?= "09a421a9b2ba044daf4ab9ea2f54a33cf7a2fac1"
SRCREV_meta ?= "bc35d5bd224ab031440a69f9806d839db382f05c"
LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel-rt_4.19.bb b/recipes-kernel/linux/linux-intel-rt_4.19.bb
index 0fd47585..edf32af0 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.19.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.19.bb
@@ -5,7 +5,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
@@ -17,8 +17,8 @@ KMETA_BRANCH = "yocto-4.19"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.19.31"
-SRCREV_machine ?= "8b4bc03e27be3bd3b23249205d11185b2ed21ec6"
-SRCREV_meta ?= "d85f07e03c980eca5ffd5ba058985d6ed3a83801"
+LINUX_VERSION ?= "4.19.59"
+SRCREV_machine ?= "d6dc301c71aea6098e5e19ef3f265d0ba9981167"
+SRCREV_meta ?= "960be4218436fbbb3500e019f7abf02fa94e6aac"
LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb
index fd82cfa6..8f51c087 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -6,7 +6,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
diff --git a/recipes-kernel/linux/linux-intel_4.14.bb b/recipes-kernel/linux/linux-intel_4.14.bb
index cc100fe8..e00eb88b 100644
--- a/recipes-kernel/linux/linux-intel_4.14.bb
+++ b/recipes-kernel/linux/linux-intel_4.14.bb
@@ -10,8 +10,8 @@ SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch \
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.14.110"
-SRCREV_machine ?= "f93147df5d96922347d0a4143ad06ae5d45d1caf"
+LINUX_VERSION ?= "4.14.138"
+SRCREV_machine ?= "3f695bb28f52f6317f034efbf42b052c66dee0e6"
SRCREV_meta ?= "bc35d5bd224ab031440a69f9806d839db382f05c"
# For Crystalforest and Romley
diff --git a/recipes-kernel/linux/linux-intel_4.19.bb b/recipes-kernel/linux/linux-intel_4.19.bb
index c3f1a9d1..eb2839bb 100644
--- a/recipes-kernel/linux/linux-intel_4.19.bb
+++ b/recipes-kernel/linux/linux-intel_4.19.bb
@@ -9,9 +9,9 @@ SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurs
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.19.40"
-SRCREV_machine ?= "106e1f78760b7e980a9598098ee45ec0a683c7ed"
-SRCREV_meta ?= "6fface2df8bc35e72aaf3d79352413fd84175879"
+LINUX_VERSION ?= "4.19.62"
+SRCREV_machine ?= "c8c1c2f3f330f4f93279a8ad842f68d40ae6fb3d"
+SRCREV_meta ?= "960be4218436fbbb3500e019f7abf02fa94e6aac"
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
diff --git a/recipes-kernel/linux/linux-intel_4.9.bb b/recipes-kernel/linux/linux-intel_4.9.bb
index 59240714..8b467c4f 100644
--- a/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/recipes-kernel/linux/linux-intel_4.9.bb
@@ -8,9 +8,9 @@ SRC_URI_append = " \
file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \
"
-LINUX_VERSION ?= "4.9.180"
-SRCREV_machine ?= "179a9cd71bbb9e153856c8e4bb44812a1ee8f8b6"
-SRCREV_meta ?= "f9e90afd4e47920e990dacb73cd6508917ca5422"
+LINUX_VERSION ?= "4.9.195"
+SRCREV_machine ?= "f1bbb927291ee709a47bb3124aa53e819e936e7b"
+SRCREV_meta ?= "01eb2cf9a6626c65a4c117249d03a002f683222d"
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"