aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.14.bb6
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.19.bb2
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.9.bb2
-rw-r--r--recipes-kernel/linux/linux-intel_4.9.bb6
4 files changed, 8 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.14.bb b/recipes-kernel/linux/linux-intel-rt_4.14.bb
index 4c7bb40c..6967ec25 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.14.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.14.bb
@@ -5,7 +5,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
@@ -17,8 +17,8 @@ SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.14.126"
-SRCREV_machine ?= "926a97a073b7c7a22387ad7663644e0cdf3ec032"
+LINUX_VERSION ?= "4.14.134"
+SRCREV_machine ?= "09a421a9b2ba044daf4ab9ea2f54a33cf7a2fac1"
SRCREV_meta ?= "bc35d5bd224ab031440a69f9806d839db382f05c"
LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel-rt_4.19.bb b/recipes-kernel/linux/linux-intel-rt_4.19.bb
index a7e272ee..edf32af0 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.19.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.19.bb
@@ -5,7 +5,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb
index fd82cfa6..8f51c087 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -6,7 +6,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
diff --git a/recipes-kernel/linux/linux-intel_4.9.bb b/recipes-kernel/linux/linux-intel_4.9.bb
index d1ba3004..8b467c4f 100644
--- a/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/recipes-kernel/linux/linux-intel_4.9.bb
@@ -8,9 +8,9 @@ SRC_URI_append = " \
file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \
"
-LINUX_VERSION ?= "4.9.183"
-SRCREV_machine ?= "107e98ee74a588750a5a80ffe11f52628295e461"
-SRCREV_meta ?= "f9e90afd4e47920e990dacb73cd6508917ca5422"
+LINUX_VERSION ?= "4.9.195"
+SRCREV_machine ?= "f1bbb927291ee709a47bb3124aa53e819e936e7b"
+SRCREV_meta ?= "01eb2cf9a6626c65a4c117249d03a002f683222d"
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"