aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16.inc3
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch30
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/qat/qat16.inc b/meta-isg/common/recipes-extended/qat/qat16.inc
index e602dbd8..822db5d8 100644
--- a/meta-isg/common/recipes-extended/qat/qat16.inc
+++ b/meta-isg/common/recipes-extended/qat/qat16.inc
@@ -14,6 +14,7 @@ PROVIDES += "virtual/qat"
SRC_URI="https://01.org/sites/default/files/page/qatmux.l.${PV}.tgz;name=qat \
file://qat16_2.3.0-34-qat-fix-for-cross-compilation-issue.patch \
file://qat16_2.3.0-34-qat-remove-local-path-from-makefile.patch \
+ file://qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch \
"
COMPATIBLE_MACHINE = "crystalforest"
@@ -46,6 +47,8 @@ PARALLEL_MAKE = ""
#To get around the double slashes in paths in QAT makefiles
PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
+EXTRA_OEMAKE_append = " CFLAGS+=-fgnu89-inline"
+
do_unpack2() {
cd ${S}/
tar xzvf ${ICP_DRIVER_TYPE}.L.${PV}.tar.gz
diff --git a/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch
new file mode 100644
index 00000000..e1ed3fc9
--- /dev/null
+++ b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch
@@ -0,0 +1,30 @@
+From 83f465ee776868875f6c19c2110eed4db6c547ce Mon Sep 17 00:00:00 2001
+From: Anuj Mittal <anujx.mittal@intel.com>
+Date: Thu, 10 Sep 2015 11:58:44 +0800
+Subject: [PATCH] qat: make sure CFLAGS are correct
+
+Upstream-Status: Submitted
+
+Ensure that all the CFLAGS values are being considered.
+
+Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
+---
+ quickassist/adf/user/user_proxy/src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/quickassist/adf/user/user_proxy/src/Makefile b/quickassist/adf/user/user_proxy/src/Makefile
+index 868313a..efd352c 100644
+--- a/quickassist/adf/user/user_proxy/src/Makefile
++++ b/quickassist/adf/user/user_proxy/src/Makefile
+@@ -133,7 +133,7 @@ INCLUDES+= -I$(ADF_DIR)/include \
+ -I$(ADF_PLATFORM_DIR)/include \
+ -I$(ADF_CTL_DIR)/include
+
+-CFLAGS = -D_GNU_SOURCE -O2 $(INCLUDES)
++CFLAGS += -D_GNU_SOURCE -O2 $(INCLUDES)
+ #needed by SAL
+ EXTRA_CFLAGS += -fPIC -fno-strict-aliasing
+ #include your $(ICP_OS)_$(ICP_OS_LEVEL).mk file
+--
+1.7.9.5
+