aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch31
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb16
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch
new file mode 100644
index 00000000..cd517052
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch
@@ -0,0 +1,31 @@
+From a424a79b1422f1877de3ee7aee6f781aeacc3630 Mon Sep 17 00:00:00 2001
+From: Anuj Mittal <anujx.mittal@intel.com>
+Date: Tue, 18 Aug 2015 12:36:02 +0800
+Subject: [PATCH] examples: add config variable to enable/disable dpdk_qat
+
+Upstream-Status: Inappropriate [configuration]
+
+Add CONFIG_EXAMPLE_DPDK_QAT to control compilation of dpdk_qat
+example by PACKAGECONFIG
+
+Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
+---
+ examples/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/Makefile b/examples/Makefile
+index b4eddbd..1bc14b0 100644
+--- a/examples/Makefile
++++ b/examples/Makefile
+@@ -41,7 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
+ DIRS-y += cmdline
+ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
+ ifneq ($(ICP_ROOT),)
+-DIRS-y += dpdk_qat
++DIRS-$(CONFIG_EXAMPLE_DPDK_QAT) += dpdk_qat
+ endif
+ DIRS-y += exception_path
+ DIRS-y += helloworld
+--
+1.7.9.5
+
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb
new file mode 100644
index 00000000..7a7af6fe
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb
@@ -0,0 +1,16 @@
+include dpdk.inc
+
+SRC_URI += "\
+ file://dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch \
+ file://dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch \
+ "
+
+SRC_URI[dpdk.md5sum] = "205a0d12bfd6eb717d57506272f43519"
+SRC_URI[dpdk.sha256sum] = "f7b322867a45f99afd9c8fbacdc56e1621676f9ca0f046656ec85eb6a99a3440"
+
+export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
+export ARCHDIR = "generic"
+
+do_configure_prepend () {
+ sed -e "s#CONFIG_RTE_LIBRTE_POWER=y#CONFIG_RTE_LIBRTE_POWER=${CONFIG_EXAMPLE_VM_POWER_MANAGER}#" -i ${S}/config/common_linuxapp
+}