aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch52
-rw-r--r--common/recipes-bsp/grub/grub_1.98.bb5
2 files changed, 55 insertions, 2 deletions
diff --git a/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch b/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch
new file mode 100644
index 00000000..d09ecf52
--- /dev/null
+++ b/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch
@@ -0,0 +1,52 @@
+Index: grub-1.98/conf/any-emu.mk
+===================================================================
+--- grub-1.98.orig/conf/any-emu.mk 2011-02-24 00:54:20.825116207 -0600
++++ grub-1.98/conf/any-emu.mk 2011-02-24 00:55:55.465116194 -0600
+@@ -820,7 +820,7 @@
+ ./gentrigtables > $@
+ DISTCLEANFILES += trigtables.c
+ gentrigtables: gentrigtables.c
+- $(CC) -o $@ $^ $(CPPFLAGS) -lm
++ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
+ DISTCLEANFILES += gentrigtables
+
+ # For grub-mkfont.
+Index: grub-1.98/conf/any-emu.rmk
+===================================================================
+--- grub-1.98.orig/conf/any-emu.rmk 2011-02-24 00:54:24.565116208 -0600
++++ grub-1.98/conf/any-emu.rmk 2011-02-24 00:56:40.665116186 -0600
+@@ -110,7 +110,7 @@
+ ./gentrigtables > $@
+ DISTCLEANFILES += trigtables.c
+ gentrigtables: gentrigtables.c
+- $(CC) -o $@ $^ $(CPPFLAGS) -lm
++ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
+ DISTCLEANFILES += gentrigtables
+
+ # For grub-mkfont.
+Index: grub-1.98/conf/common.mk
+===================================================================
+--- grub-1.98.orig/conf/common.mk 2011-02-24 00:54:30.345116207 -0600
++++ grub-1.98/conf/common.mk 2011-02-24 00:57:08.415116181 -0600
+@@ -11159,7 +11159,7 @@
+ ./gentrigtables > $@
+ DISTCLEANFILES += trigtables.c
+ gentrigtables: gentrigtables.c
+- $(CC) -o $@ $^ $(CPPFLAGS) -lm
++ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
+ DISTCLEANFILES += gentrigtables
+
+ pkglib_MODULES += setjmp.mod
+Index: grub-1.98/conf/common.rmk
+===================================================================
+--- grub-1.98.orig/conf/common.rmk 2011-02-24 00:54:34.035116205 -0600
++++ grub-1.98/conf/common.rmk 2011-02-24 00:57:31.045116179 -0600
+@@ -736,7 +736,7 @@
+ ./gentrigtables > $@
+ DISTCLEANFILES += trigtables.c
+ gentrigtables: gentrigtables.c
+- $(CC) -o $@ $^ $(CPPFLAGS) -lm
++ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
+ DISTCLEANFILES += gentrigtables
+
+ pkglib_MODULES += setjmp.mod
diff --git a/common/recipes-bsp/grub/grub_1.98.bb b/common/recipes-bsp/grub/grub_1.98.bb
index b9d04fc5..0cd3a403 100644
--- a/common/recipes-bsp/grub/grub_1.98.bb
+++ b/common/recipes-bsp/grub/grub_1.98.bb
@@ -12,12 +12,13 @@ PRIORITY = "optional"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-RDEPENDS = "diffutils"
-PR = "r0"
+RDEPENDS = "diffutils freetype"
+PR = "r1"
SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz \
file://uninit-shdr-fix.patch;apply=yes \
file://grub-install.in.patch;apply=yes \
+ file://gentrigtables-compile-fix.patch;apply=yes \
file://40_custom"
inherit autotools