summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-bsp/rmc/rmc.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/common/recipes-bsp/rmc/rmc.bb b/common/recipes-bsp/rmc/rmc.bb
index 8c89a99c..f5c648d8 100644
--- a/common/recipes-bsp/rmc/rmc.bb
+++ b/common/recipes-bsp/rmc/rmc.bb
@@ -22,6 +22,11 @@ COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux*"
TARGET_CFLAGS +="-Wl,--hash-style=both"
+EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
+ RMC_INSTALL_BIN_PATH=${D}${bindir} \
+ RMC_INSTALL_LIB_PATH=${D}${libdir} \
+ RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
+
SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
do_compile_class-target() {
oe_runmake
@@ -29,8 +34,8 @@ do_compile_class-target() {
}
do_install() {
- oe_runmake RMC_INSTALL_PREFIX=${D}/usr install
- oe_runmake RMC_INSTALL_PREFIX=${D}/usr -f Makefile.efi install
+ oe_runmake install
+ oe_runmake -f Makefile.efi install
}
do_install_class-native() {