summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-crownbay/README10
-rw-r--r--meta-crownbay/conf/machine/crownbay.conf2
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend4
3 files changed, 8 insertions, 8 deletions
diff --git a/meta-crownbay/README b/meta-crownbay/README
index f236d8f4..4b539b60 100644
--- a/meta-crownbay/README
+++ b/meta-crownbay/README
@@ -6,7 +6,7 @@ The Crown Bay platform consists of the Intel Atom E6xx processor,
plus the Intel EG20T Platform Controller Hub (Tunnel Creek + Topcliff).
It also supports the E6xx embedded on-chip graphics via the Intel
-Embedded Media and Graphics Driver (EMGD) 1.14 Driver.
+Embedded Media and Graphics Driver (EMGD) 1.16 Driver.
Further information on the platforms supported by this BSP can be
found here:
@@ -81,7 +81,7 @@ common metadata shared between BSPs) e.g.:
The meta-crownbay layer contains support for two different machine
configurations. These configurations are identical except for the fact
that the one prefixed with 'crownbay' makes use of the
-Intel-proprietary EMGD 1.14 graphics driver, while the one prefixed
+Intel-proprietary EMGD 1.16 graphics driver, while the one prefixed
with 'crownbay-noemgd' does not.
If you want to enable the layer that supports EMGD graphics add the
@@ -91,10 +91,10 @@ following to the local.conf file:
The 'crownbay' machine includes the emgd-driver-bin package, which has
a proprietary license that must be whitelisted by adding the string
-"license_emgd-driver-bin_1.14" to the LICENSE_FLAGS_WHITELIST variable
+"license_emgd-driver-bin_1.16" to the LICENSE_FLAGS_WHITELIST variable
in your local.conf. For example:
- LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.14"
+ LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.16"
If you want to enable the layer that does not support EMGD graphics
add the following to the local.conf file:
@@ -116,7 +116,7 @@ added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
For example:
- LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.14 commercial"
+ LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.16 commercial"
The reason this is needed is to prevent the image from including
anything that might violate the license terms of the packages used to
diff --git a/meta-crownbay/conf/machine/crownbay.conf b/meta-crownbay/conf/machine/crownbay.conf
index 7324c61f..e714a948 100644
--- a/meta-crownbay/conf/machine/crownbay.conf
+++ b/meta-crownbay/conf/machine/crownbay.conf
@@ -22,7 +22,7 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
PREFERRED_VERSION_xserver-xorg ?= "1.9.3"
PREFERRED_VERSION_mesa-dri ?= "8.0.4"
PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0"
-PREFERRED_VERSION_emgd-driver-bin ?= "1.14"
+PREFERRED_VERSION_emgd-driver-bin ?= "1.16"
APPEND += "video=vesafb vga=0x318 vmalloc=256MB"
diff --git a/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 01ffb4d3..0f12dea4 100644
--- a/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
COMPATIBLE_MACHINE_crownbay = "crownbay"
KMACHINE_crownbay = "crownbay"
KBRANCH_crownbay = "standard/crownbay"
-KERNEL_FEATURES_crownbay_append = " features/drm-emgd cfg/vesafb"
+KERNEL_FEATURES_crownbay_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
KMACHINE_crownbay-noemgd = "crownbay"
@@ -17,5 +17,5 @@ SRCREV_emgd_pn-linux-yocto_crownbay ?= "${AUTOREV}"
SRCREV_machine_pn-linux-yocto_crownbay-noemgd ?= "${AUTOREV}"
SRCREV_meta_pn-linux-yocto_crownbay-noemgd ?= "${AUTOREV}"
-SRC_URI_crownbay = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.14;name=machine,meta,emgd"
+SRC_URI_crownbay = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"
SRC_URI_crownbay-noemgd = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA};name=machine,meta"