summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb11
-rw-r--r--meta-crystalforest/README21
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-gladden.conf1
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-server.conf1
4 files changed, 21 insertions, 13 deletions
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
index fb863b0a..fdeebbb8 100644
--- a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
+++ b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
@@ -45,14 +45,6 @@ do_compile() {
oe_runmake KERNEL_CC="${KERNEL_CC}"
}
-KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
-MODULE_DIR="${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"
-
-do_install() {
- install -m 0755 -d ${MODULE_DIR}
- install -m 0755 ${S}/qat_mem.ko ${MODULE_DIR}
-}
-
do_install_append() {
install -m 0755 -d ${D}${bindir} \
${D}${includedir}/engines/qat_engine/qat_mem
@@ -61,5 +53,4 @@ do_install_append() {
install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/
}
-FILES_${PN} += "${bindir}/qat_mem_test \
- ${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"
+FILES_${PN} += "${bindir}/qat_mem_test"
diff --git a/meta-crystalforest/README b/meta-crystalforest/README
index e658039a..625bdbc7 100644
--- a/meta-crystalforest/README
+++ b/meta-crystalforest/README
@@ -74,7 +74,7 @@ Table of Contents
I. Building the meta-crystalforest BSP layer
II. Booting the images in /binary
III. Enabling Intel DPDK and QuickAssist Technology
-
+IV. Enabling libcrypto kernel module for QuickAssist Technology
I. Building the meta-crystalforest BSP layer
=======================================
@@ -165,6 +165,25 @@ contact your Intel Field Sales Representative or visit Intel Embedded Design
Center (www.intel.com/p/en_US/embedded/designcenter) for instructions on how
to locate and use these recipes.
+IV. Enabling libcrypto kernel module for QuickAssist Technology
+===============================================================
+
+Since the Kernel Module names of Libcrypto and Zlib for QuickAssist
+Technology recipes are same, enabling both causes the build to fail.
+
+Please see Bug #4126 for more description.
+
+By default Crystal Forest builds zlib-qat-module.
+For enabling the libcrypto kernel module recipe, do the following:
+
+Crystal Forest Gladden:
+Edit meta-intel/meta-crystalforest/conf/machine/crystalforest-gladden.conf
+and replace zlib-qat-module with openssl-qat-module in MACHINE_EXTRA_RRECOMMENDS
+
+Crystal Forest Server:
+Edit meta-intel/meta-crystalforest/conf/machine/crystalforest-server.conf
+and replace zlib-qat-module with openssl-qat-module in MACHINE_EXTRA_RRECOMMENDS
+
----
If you find you're getting corrupt images on the USB (it doesn't show
diff --git a/meta-crystalforest/conf/machine/crystalforest-gladden.conf b/meta-crystalforest/conf/machine/crystalforest-gladden.conf
index 5eb3daff..2615d7a6 100644
--- a/meta-crystalforest/conf/machine/crystalforest-gladden.conf
+++ b/meta-crystalforest/conf/machine/crystalforest-gladden.conf
@@ -22,7 +22,6 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \
canterbury-corpus \
zlib-qat-module \
- openssl-qat-module \
"
#This Kernel Option is required for Intel Quick Assist Technology Software.
APPEND += "acpi_enforce_resources=lax"
diff --git a/meta-crystalforest/conf/machine/crystalforest-server.conf b/meta-crystalforest/conf/machine/crystalforest-server.conf
index 2e567978..443ac056 100644
--- a/meta-crystalforest/conf/machine/crystalforest-server.conf
+++ b/meta-crystalforest/conf/machine/crystalforest-server.conf
@@ -22,7 +22,6 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \
canterbury-corpus \
zlib-qat-module \
- openssl-qat-module \
"
#This Kernel Option is required for Intel Quick Assist Technology Software.
APPEND += "acpi_enforce_resources=lax"