aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-n450/conf/machine/n450.conf2
-rw-r--r--meta-n450/recipes-bsp/n450-audio/n450-audio.bb30
-rw-r--r--meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio42
3 files changed, 0 insertions, 74 deletions
diff --git a/meta-n450/conf/machine/n450.conf b/meta-n450/conf/machine/n450.conf
index 3e6a5418..6ffdce99 100644
--- a/meta-n450/conf/machine/n450.conf
+++ b/meta-n450/conf/machine/n450.conf
@@ -14,5 +14,3 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
SYSLINUX_OPTS = "serial 0 115200"
SERIAL_CONSOLE = "115200 ttyS0"
APPEND += "console=ttyS0,115200 console=tty0"
-
-MACHINE_EXTRA_RRECOMMENDS += "n450-audio"
diff --git a/meta-n450/recipes-bsp/n450-audio/n450-audio.bb b/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
deleted file mode 100644
index 27904e32..00000000
--- a/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Provide a basic init script to enable audio"
-DESCRIPTION = "Set the volume and unmute the Front mixer setting during boot."
-SECTION = "base"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-PR = "r4"
-
-inherit update-rc.d
-
-RDEPENDS = "alsa-utils-amixer"
-
-SRC_URI = "file://n450-audio"
-
-INITSCRIPT_NAME = "n450-audio"
-INITSCRIPT_PARAMS = "defaults 90"
-
-do_install() {
- install -d ${D}${sysconfdir} \
- ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/n450-audio ${D}${sysconfdir}/init.d
- cat ${WORKDIR}/${INITSCRIPT_NAME} | \
- sed -e 's,/etc,${sysconfdir},g' \
- -e 's,/usr/sbin,${sbindir},g' \
- -e 's,/var,${localstatedir},g' \
- -e 's,/usr/bin,${bindir},g' \
- -e 's,/usr,${prefix},g' > ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
- chmod 755 ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
-}
-
diff --git a/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio b/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio
deleted file mode 100644
index c5a0044b..00000000
--- a/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: n450 mixer setup
-# Required-Start: $syslog
-# Required-Stop: $syslog
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: Initialize the n450 audio mixer
-# Description: Unmute FRONT and set volume to ~70%.
-### END INIT INFO
-
-# Author: Darren Hart <dvhart@linux.intel.com>
-# Based on /etc/init.d/skeleton
-
-PATH=/sbin:/usr/sbin:/bin:/usr/bin
-DESC="Audio mixer settings"
-NAME=n450-audio
-AMIXER=`which amixer`
-SCRIPTNAME=/etc/init.d/$NAME
-
-# Exit if amixer is not installed
-[ -x "$AMIXER" ] || exit 0
-
-do_start() {
- # Enable the "Front" simple controls (black phones jack)
- $AMIXER sset Front 30 on > /dev/null
-}
-
-case "$1" in
-start)
- echo "$NAME: setting default mixer settings."
- do_start
- ;;
-stop)
- ;;
-*)
- echo "Usage: $SCRIPTNAME {start|stop}" >&2
- exit 3
- ;;
-esac
-
-exit 0