aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-tlk/README6
-rw-r--r--meta-tlk/conf/layer.conf6
-rw-r--r--meta-tlk/recipes-kernel/linux/linux-yocto/time-limited-kernel.cfg3
-rw-r--r--meta-tlk/recipes-kernel/linux/linux-yocto_3.0.bbappend4
4 files changed, 19 insertions, 0 deletions
diff --git a/meta-tlk/README b/meta-tlk/README
new file mode 100644
index 00000000..5ff4d3bc
--- /dev/null
+++ b/meta-tlk/README
@@ -0,0 +1,6 @@
+meta-autobuilder
+===============
+
+Contains recipe modifications required to produce the official
+yocto autobuild BSPs.
+
diff --git a/meta-tlk/conf/layer.conf b/meta-tlk/conf/layer.conf
new file mode 100644
index 00000000..9af646f0
--- /dev/null
+++ b/meta-tlk/conf/layer.conf
@@ -0,0 +1,6 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}:${LAYERDIR}"
+
+# We have a packages directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
diff --git a/meta-tlk/recipes-kernel/linux/linux-yocto/time-limited-kernel.cfg b/meta-tlk/recipes-kernel/linux/linux-yocto/time-limited-kernel.cfg
new file mode 100644
index 00000000..44f4beaa
--- /dev/null
+++ b/meta-tlk/recipes-kernel/linux/linux-yocto/time-limited-kernel.cfg
@@ -0,0 +1,3 @@
+CONFIG_UPTIME_LIMITED_KERNEL=y
+CONFIG_UPTIME_LIMIT_DURATION=14400
+CONFIG_UPTIME_LIMIT_KERNEL_REBOOT=y
diff --git a/meta-tlk/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-tlk/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 00000000..58a6541c
--- /dev/null
+++ b/meta-tlk/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# enable the time limited kernel configuration options
+SRC_URI += "file://time-limited-kernel.cfg"