summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb6
-rw-r--r--meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb3
2 files changed, 7 insertions, 2 deletions
diff --git a/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
index d0e14a56..5153054c 100644
--- a/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
+++ b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Userspace interface to kernel DRM services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7"
-PR = "r4"
+PR = "r5"
PROVIDES = "libdrm-poulsbo"
@@ -17,3 +17,7 @@ do_configure_prepend() {
sed -e 's/-ldrm/-ldrm_poulsbo/' -e 's/libdrm/libdrm_poulsbo/' \
< ${S}/libdrm.pc.in > ${S}/libdrm_poulsbo.pc.in
}
+
+do_install_append() {
+ ln -s libdrm_poulsbo.so.2.3.0 ${D}${libdir}/libdrm.so.2
+}
diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
index f4b43ab0..0d675c6d 100644
--- a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
+++ b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "X11 drivers for Poulsbo (psb) 3D acceleration"
# not Intel proprietary, but it has no obvious license attached to it.
LICENSE = "Intel-binary-only"
LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=02c597a2f082b4581596065bb5a521a8"
-PR = "r6"
+PR = "r7"
inherit autotools
@@ -29,6 +29,7 @@ do_install() {
${D}/${libdir}/xorg/modules/dri
install -m 0644 ${WORKDIR}/${PN}-${PV}/drivers/* \
${D}/${libdir}/xorg/modules/drivers
+ ln -s ${libdir}/xorg/modules/dri ${D}${libdir}/dri
}
S = "${WORKDIR}/${PN}-${PV}/mesa"