aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-04-20 19:14:38 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2013-04-22 22:36:28 -0500
commit2e1cc12ddb955fa558f42e1845d42e7f65a5156a (patch)
tree566fe37dd9a3e19a58f13560c133deb343c6a1b8
parentb237e2acaee4316ccc67a0603c35967d66348346 (diff)
downloadmeta-intel-2e1cc12ddb955fa558f42e1845d42e7f65a5156a.tar.gz
meta-intel-2e1cc12ddb955fa558f42e1845d42e7f65a5156a.tar.bz2
meta-intel-2e1cc12ddb955fa558f42e1845d42e7f65a5156a.zip
emgd-driver-bin: do not provide gl.pc
Remove the previously added gl.pc from the emgd recipe. emgd recipe does not provide libGL, still the associated gl.pc file was provided in the recipe, which causes conflicts with other recipes as seen below. These kind of errors are fixed with this commit. | Collected errors: | * check_data_file_clashes: Package libgl-mesa-dev wants to install file /srv/home/nitin/build-test-bsps/build-emenlow/tmp/work/emenlow-poky-linux/core-image-sato-sdk/1.0-r0/rootfs/usr/lib/pkgconfig/gl.pc | But that file is already provided by package * emgd-driver-dev | * opkg_install_cmd: Cannot install package qt4-x11-free-dev. | * check_data_file_clashes: Package libgl-mesa-dev wants to install file /srv/home/nitin/build-test-bsps/build-emenlow/tmp/work/emenlow-poky-linux/core-image-sato-sdk/1.0-r0/rootfs/usr/lib/pkgconfig/gl.pc | But that file is already provided by package * emgd-driver-dev | * opkg_install_cmd: Cannot install package mesa-demos-dev. | * check_data_file_clashes: Package libgl-mesa-dev wants to install file /srv/home/nitin/build-test-bsps/build-emenlow/tmp/work/emenlow-poky-linux/core-image-sato-sdk/1.0-r0/rootfs/usr/lib/pkgconfig/gl.pc | But that file is already provided by package * emgd-driver-dev | * opkg_install_cmd: Cannot install package libva-egl-dev. | * check_data_file_clashes: Package libgl-mesa-dev wants to install file /srv/home/nitin/build-test-bsps/build-emenlow/tmp/work/emenlow-poky-linux/core-image-sato-sdk/1.0-r0/rootfs/usr/lib/pkgconfig/gl.pc | But that file is already provided by package * emgd-driver-dev | * opkg_install_cmd: Cannot install package libva-glx-dev. | * check_data_file_clashes: Package libgl-mesa-dev wants to install file /srv/home/nitin/build-test-bsps/build-emenlow/tmp/work/emenlow-poky-linux/core-image-sato-sdk/1.0-r0/rootfs/usr/lib/pkgconfig/gl.pc | But that file is already provided by package * emgd-driver-dev | * opkg_install_cmd: Cannot install package libgl-mesa-dev. | ERROR: Function failed: do_rootfs (see | /srv/home/nitin/build-test-bsps/build-emenlow/tmp/work/emenlow-poky-li | nux/core-image-sato-sdk/1.0-r0/temp/log.do_rootfs.49983 for further | information) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Tested-by: Tom Zanussi <tom.zanussi@linux.intel.com>
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin/gl.pc13
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb1
2 files changed, 0 insertions, 14 deletions
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin/gl.pc b/common/recipes-graphics/xorg-driver/emgd-driver-bin/gl.pc
deleted file mode 100644
index bf07495b..00000000
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin/gl.pc
+++ /dev/null
@@ -1,13 +0,0 @@
-prefix=/usr
-exec_prefix=${prefix}
-libdir=/usr/lib
-includedir=/usr/include
-
-Name: gl
-Description: EMGD OpenGL library
-Requires.private:
-Version: 1.16
-Libs: -L${libdir} -lGL
-Libs.private: -lm -lpthread -ldl
-Cflags: -I${includedir}
-glx_tls: yes
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
index c9c1ecc5..0dc1de1d 100644
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
+++ b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
@@ -30,7 +30,6 @@ python populate_packages_prepend() {
SRC_URI = "https://edc.intel.com/App_Shared/Downloads/LIN_IEMGD_1_16_GOLD_3228.tgz \
file://egl.pc \
- file://gl.pc \
file://gles_cm.pc \
file://glesv2.pc \
"