aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-08-21 20:53:51 +0000
committerTom Zanussi <tom.zanussi@linux.intel.com>2013-09-05 08:20:21 -0500
commit662865482570f698571596764f1cfc748338c436 (patch)
tree9fffb519076539aa6332a1cc79b4e553d94eb16a
parent164067980e18e8ba60b317677ced2d75c3725dbe (diff)
downloadmeta-intel-662865482570f698571596764f1cfc748338c436.tar.gz
meta-intel-662865482570f698571596764f1cfc748338c436.tar.bz2
meta-intel-662865482570f698571596764f1cfc748338c436.zip
emgd-driver-bin: mark opengl as a required distro feature
emgd recipe needs 'opengl' distro feature enabled. Otherwise target image build fails without much clue. This commit is marking the 'opengl' as a required distro feature, which helps user understand the distro configuration issue in case the requirement of distro features is not met. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-By: Ross Burton <ross.burton@intel.com>
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb3
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
index af07c37f..4cb7b8a0 100644
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
+++ b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
@@ -28,6 +28,9 @@ python populate_packages_prepend() {
d.appendVar("RDEPENDS_" + pn, " xorg-abi-video-8")
}
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "opengl"
+
SRC_URI = "https://edc.intel.com/App_Shared/Downloads/LIN_IEMGD_1_16_GOLD_3228.tgz \
file://egl.pc \
file://gles_cm.pc \
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
index 4add5fbd..b659a8b4 100644
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
+++ b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
@@ -28,6 +28,9 @@ python populate_packages_prepend() {
d.appendVar("RDEPENDS_" + pn, " xorg-abi-video-8")
}
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "opengl"
+
SRC_URI = "http://downloadmirror.intel.com/22865/eng/LIN_IEMGD_1_18_GOLD_3398.tgz \
file://egl.pc \
file://gles_cm.pc \