aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-08-02 16:14:15 +0000
committerDarren Hart <dvhart@linux.intel.com>2013-08-02 13:07:14 -0700
commit5ec92f4e2407f4d5a86333f9c27a4ebadb8f2e07 (patch)
tree80c614816afc04ae9a92c7ce1318be1470202e22
parent2a8668b39b28e0bdec2dec9b11856d758657e2fe (diff)
downloadmeta-intel-5ec92f4e2407f4d5a86333f9c27a4ebadb8f2e07.tar.gz
meta-intel-5ec92f4e2407f4d5a86333f9c27a4ebadb8f2e07.tar.bz2
meta-intel-5ec92f4e2407f4d5a86333f9c27a4ebadb8f2e07.zip
emgd-driver-bin-1.18: fix for xorg-abi-video error
This issues was already fixed for the emgd-driver-bin-1.16 recipe as seen in the commit message below. Now reapplying the same fix to the emgd-driver-bin-1.18 recipe. commit edf3ef3cca449c7a631bab3fd0fed580378629e9 Author: Nitin A Kamble <nitin.a.kamble@intel.com> Date: Mon Jun 10 14:20:20 2013 -0700 emgd-driver-bin: add xserver-xorg to RDEPENDS When any package using libraries provided by the emgd-driver-bin recipe, is included in a image (such as: tools-testapps), the rootfs generation process encounters an error mentioned below. The code for checking the abi version of the xorg xserver needs xorg xserver recipe included in the image. Otherwise it gets following rootfs generation error: | Computing transaction...error: Can't install emgd-driver-1.16-r0@core2: no package provides xorg-abi-video-8 Fix the issue by marking xserver-xorg as a dependency of the emgd-driver-bin recipe. Fixes this bug: [YOCTO #4615] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
index 705b1203..4add5fbd 100644
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
+++ b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
@@ -7,7 +7,7 @@ to LICENSE_FLAGS_WHITELIST += \"license_emgd-driver-bin_1.18\" to your \
local.conf in order to enable it in a build."
LICENSE = "Intel-software-license-emgd-1.18 & Intel-user-space-graphics-driver-binary-license-emgd-1.18"
LICENSE_FLAGS = "license_${PN}_${PV}"
-PR = "r0"
+PR = "r1"
EMGD_LIC_DIR = "IEMGD_HEAD_Linux/License"
EMGD_RPM_DIR = "IEMGD_HEAD_Linux/MeeGo1.2"
@@ -17,7 +17,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/${EMGD_LIC_DIR}/License.txt;md5=7ce256e6a3
file://${WORKDIR}/${EMGD_LIC_DIR}/readme.txt;md5=73cbec7a0d2bc22faf567238e055bfc8"
DEPENDS = "rpm-native xz-native"
-RDEPENDS_${PN} = "libxcb-dri2 cairo"
+RDEPENDS_${PN} = "libxcb-dri2 cairo xserver-xorg"
# Add the ABI dependency at package generation time, as otherwise bitbake will
# attempt to find a provider for it (and fail) when it does the parse.