aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/files/features/perf/perf-change-root-to-prefix-for-python-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/files/features/perf/perf-change-root-to-prefix-for-python-install.patch')
-rw-r--r--recipes-kernel/linux/files/features/perf/perf-change-root-to-prefix-for-python-install.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/features/perf/perf-change-root-to-prefix-for-python-install.patch b/recipes-kernel/linux/files/features/perf/perf-change-root-to-prefix-for-python-install.patch
new file mode 100644
index 0000000..4fdbd67
--- /dev/null
+++ b/recipes-kernel/linux/files/features/perf/perf-change-root-to-prefix-for-python-install.patch
@@ -0,0 +1,29 @@
+From 49f1599b2ce0288599805b5364b895f5a9febb3e Mon Sep 17 00:00:00 2001
+From: Tom Zanussi <tom.zanussi@intel.com>
+Date: Tue, 3 Jul 2012 13:07:23 -0500
+Subject: [PATCH 3/3] perf: change --root to --prefix for python install
+
+Otherwise we get the sysroot path appended to the build path, not what
+we want.
+
+Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
+---
+ tools/perf/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tools/perf/Makefile b/tools/perf/Makefile
+index f966313..15ec207 100644
+--- a/tools/perf/Makefile
++++ b/tools/perf/Makefile
+@@ -954,7 +954,7 @@ install: all
+ $(INSTALL) scripts/python/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin'
+
+ install-python_ext:
+- $(PYTHON_WORD) util/setup.py --quiet install --root='/$(DESTDIR_SQ)'
++ $(PYTHON_WORD) util/setup.py --quiet install --prefix='$(DESTDIR_SQ)/usr'
+
+ install-doc:
+ $(MAKE) -C Documentation install
+--
+1.7.5.4
+