aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf11
-rw-r--r--conf/machine/clanton.conf21
2 files changed, 32 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..7891979
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,11 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}:${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "clanton-bsp"
+BBFILE_PATTERN_clanton-bsp := "^${LAYERDIR}/"
+BBFILE_PRIORITY_clanton-bsp = "6"
+
diff --git a/conf/machine/clanton.conf b/conf/machine/clanton.conf
new file mode 100644
index 0000000..3304e3c
--- /dev/null
+++ b/conf/machine/clanton.conf
@@ -0,0 +1,21 @@
+#@TYPE: Machine
+#@NAME: clanton
+
+#@DESCRIPTION: Machine configuration for clanton systems
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto-clanton"
+PREFERRED_VERSION_linux-yocto-clanton ?= "3.8%"
+
+require conf/machine/include/ia32-base.inc
+include conf/machine/include/tune-i586.inc
+
+#Avoid pulling in GRUB
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS = ""
+
+MACHINE_FEATURES = "efi usb pci"
+
+SERIAL_CONSOLE = "115200 ttyS1"
+#SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
+
+EXTRA_IMAGEDEPENDS = "grub"
+PREFERRED_VERSION_grub = "0.97+git%"