aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/quark-init/files/galileo.conf8
-rw-r--r--recipes-kernel/quark-init/files/galileo_gen2.conf9
-rw-r--r--recipes-kernel/quark-init/files/quark-init.service10
-rwxr-xr-xrecipes-kernel/quark-init/files/quark-init.sh28
-rw-r--r--recipes-kernel/quark-init/quark-init_0.1.bb33
5 files changed, 0 insertions, 88 deletions
diff --git a/recipes-kernel/quark-init/files/galileo.conf b/recipes-kernel/quark-init/files/galileo.conf
deleted file mode 100644
index daed921..0000000
--- a/recipes-kernel/quark-init/files/galileo.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-intel_qrk_gip
-cy8c9540a
-i2c_dev
-spidev
-spi-pxa2xx-pci
-spi-pxa2xx
-industrialio
-ad7298
diff --git a/recipes-kernel/quark-init/files/galileo_gen2.conf b/recipes-kernel/quark-init/files/galileo_gen2.conf
deleted file mode 100644
index 45b9f8f..0000000
--- a/recipes-kernel/quark-init/files/galileo_gen2.conf
+++ /dev/null
@@ -1,9 +0,0 @@
-intel_qrk_gip
-gpio-pca953x
-pca9685
-i2c_dev
-spidev
-spi-pxa2xx-pci
-spi-pxa2xx
-industrialio
-adc1x8s102
diff --git a/recipes-kernel/quark-init/files/quark-init.service b/recipes-kernel/quark-init/files/quark-init.service
deleted file mode 100644
index da24c9a..0000000
--- a/recipes-kernel/quark-init/files/quark-init.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Load modules for galileo/quark
-DefaultDependencies=no
-
-[Service]
-Type=oneshot
-ExecStart=/bin/sh /usr/sbin/quark-init.sh
-
-[Install]
-WantedBy=local-fs.target
diff --git a/recipes-kernel/quark-init/files/quark-init.sh b/recipes-kernel/quark-init/files/quark-init.sh
deleted file mode 100755
index f7c92eb..0000000
--- a/recipes-kernel/quark-init/files/quark-init.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-
-load_drivers()
-{
- while IFS= read -r line; do
- modprobe $line
- done < "/etc/modules-load.quark/$1.conf"
-}
-
-do_board()
-{
- board=$(cat /sys/devices/virtual/dmi/id/board_name)
- case "$board" in
- *"GalileoGen2" )
- load_drivers "galileo_gen2" ;;
- *"Galileo" )
- load_drivers "galileo" ;;
- esac
-}
-
-die()
-{
- exit 1
-}
-
-do_board
-exit 0
-
diff --git a/recipes-kernel/quark-init/quark-init_0.1.bb b/recipes-kernel/quark-init/quark-init_0.1.bb
deleted file mode 100644
index 026efa5..0000000
--- a/recipes-kernel/quark-init/quark-init_0.1.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-DESCRIPTION = "List of drivers to be auto-loaded"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI = "file://quark-init.sh \
- file://galileo.conf \
- file://galileo_gen2.conf \
- file://quark-init.service"
-
-INSTALLDIR = "/etc/modules-load.quark"
-FILES_${PN} += "${INSTALLDIR} \
- ${sbindir}/quark-init.sh"
-FILES_${PN}-dbg += "${INSTALLDIR}/.debug"
-
-do_install() {
- install -d ${D}${INSTALLDIR}
- install -m 0755 ${WORKDIR}/galileo.conf ${D}${INSTALLDIR}/
- install -m 0755 ${WORKDIR}/galileo_gen2.conf ${D}${INSTALLDIR}/
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/quark-init.sh ${D}${sysconfdir}/init.d
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/quark-init.service ${D}${systemd_unitdir}/system/
- install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/quark-init.sh ${D}${sbindir}
-}
-
-inherit update-rc.d systemd
-
-INITSCRIPT_NAME = "quark-init.sh"
-INITSCRIPT_PARAMS = "start 75 5 ."
-
-SYSTEMD_SERVICE_${PN} = "quark-init.service"