aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/upm/files/ads1x15-fixed-case-logic-in-getThresh-function.patch54
-rw-r--r--recipes-devtools/upm/upm_git.bb42
2 files changed, 0 insertions, 96 deletions
diff --git a/recipes-devtools/upm/files/ads1x15-fixed-case-logic-in-getThresh-function.patch b/recipes-devtools/upm/files/ads1x15-fixed-case-logic-in-getThresh-function.patch
deleted file mode 100644
index c617d14..0000000
--- a/recipes-devtools/upm/files/ads1x15-fixed-case-logic-in-getThresh-function.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From c64d04d084f47b4cb3e1cdee6e96348fcc6a756e Mon Sep 17 00:00:00 2001
-From: Mihai Tudor Panu <mihai.tudor.panu@intel.com>
-Date: Tue, 30 May 2017 15:14:09 -0700
-Subject: [PATCH 1/1] ads1x15: fixed case logic in getThresh() function
-
-Signed-off-by: Mihai Tudor Panu <mihai.tudor.panu@intel.com>
-
-Upstream-Status: Backported [c64d04d084f47b4cb3e1cdee6e96348fcc6a756e]
-
-Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
-
----
- src/ads1x15/ads1x15.cxx | 4 ++--
- src/ads1x15/ads1x15.hpp | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/ads1x15/ads1x15.cxx b/src/ads1x15/ads1x15.cxx
-index 35782709..47701b2a 100644
---- a/src/ads1x15/ads1x15.cxx
-+++ b/src/ads1x15/ads1x15.cxx
-@@ -116,7 +116,7 @@ ADS1X15::setContinuous(bool mode){
-
- float
- ADS1X15::getThresh(ADSTHRESH reg){
-- if( THRESH_HIGH && THRESH_LOW) return getLastSample(reg);
-+ if(reg == THRESH_HIGH || reg == THRESH_LOW) return getLastSample(reg);
- else return 0.0;
- }
-
-@@ -137,7 +137,7 @@ ADS1X15::setThresh(ADSTHRESH reg, float value){
- case 2:
- case 3:
- set_value = value / getMultiplier();
-- set_value = set_value << m_bitShift;
-+ set_value = set_value << m_bitShift;
- if(i2c->writeWordReg(reg, swapWord(set_value)) != mraa::SUCCESS){
- throw std::runtime_error(std::string(__FUNCTION__) + ": I2c.write() failed");
- return;
-diff --git a/src/ads1x15/ads1x15.hpp b/src/ads1x15/ads1x15.hpp
-index 7524572d..efd8c8ec 100644
---- a/src/ads1x15/ads1x15.hpp
-+++ b/src/ads1x15/ads1x15.hpp
-@@ -390,7 +390,7 @@ namespace upm {
- * @param reg ADSTHRES enum value.
- * Returns 0.0 unless THRESH_HIGH or THRESH_LOW requested.
- */
-- float getThresh(ADSTHRESH reg = THRESH_LOW);
-+ float getThresh(ADSTHRESH reg = THRESH_DEFAULT);
-
- /**
- * Sets threshold levels or configures for conversion ready
---
-2.11.0
-
diff --git a/recipes-devtools/upm/upm_git.bb b/recipes-devtools/upm/upm_git.bb
deleted file mode 100644
index d3cd43e..0000000
--- a/recipes-devtools/upm/upm_git.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-SUMMARY = "Sensor/Actuator repository for Mraa"
-SECTION = "libs"
-AUTHOR = "Brendan Le Foll, Tom Ingleby, Yevgeniy Kiveisha, Dmitry Rozhkov"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=66493d54e65bfc12c7983ff2e884f37f"
-
-DEPENDS = "libjpeg-turbo mraa"
-
-SRCREV = "106b6c706268522ab0168a4ddb19e89ce832e084"
-PV = "1.3.0-git${SRCPV}"
-
-SRC_URI = " \
- git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \
- file://ads1x15-fixed-case-logic-in-getThresh-function.patch \
-"
-
-S = "${WORKDIR}/git"
-
-inherit distutils3-base cmake
-
-
-# override this in local.conf to get needed bindings.
-# BINDINGS_pn-mraa="python"
-# will result in only the python bindings being built/packaged.
-BINDINGS ??= "python ${@ 'nodejs' if oe.types.boolean(d.getVar('HAVE_NODEJS') or '0') else '' }"
-
-PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \
- ${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}"
-
-PACKAGECONFIG[python] = "-DBUILDSWIGPYTHON=ON, -DBUILDSWIGPYTHON=OFF, swig-native ${PYTHON_PN},"
-PACKAGECONFIG[nodejs] = "-DBUILDSWIGNODE=ON, -DBUILDSWIGNODE=OFF, swig-native nodejs-native,"
-
-FILES_${PYTHON_PN}-${PN} = "${PYTHON_SITEPACKAGES_DIR}"
-RDEPENDS_${PYTHON_PN}-${PN} += "${PYTHON_PN}"
-
-FILES_node-${PN} = "${prefix}/lib/node_modules/"
-RDEPENDS_node-${PN} += "nodejs"
-
-### Include desired language bindings ###
-PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'nodejs', 'node-${PN}', '', d)}"
-PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'python', '${PYTHON_PN}-${PN}', '', d)}"