aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/cc-oci-artifacts/cc-image_16050.bb15
-rw-r--r--recipes-devtools/cc-oci-artifacts/cc-kernel_4.9.33-74.bb19
-rw-r--r--recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch26
-rw-r--r--recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-hypervisor.in-set-default-machine-to-q35.patch26
-rw-r--r--recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb37
-rw-r--r--recipes-devtools/qemu-cc/qemu-cc.bb85
6 files changed, 208 insertions, 0 deletions
diff --git a/recipes-devtools/cc-oci-artifacts/cc-image_16050.bb b/recipes-devtools/cc-oci-artifacts/cc-image_16050.bb
new file mode 100644
index 0000000..1849e94
--- /dev/null
+++ b/recipes-devtools/cc-oci-artifacts/cc-image_16050.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPLv2"
+ERROR_QA_remove = "license-checksum"
+
+SRC_URI = "https://download.clearlinux.org/releases/16050/clear/clear-${PV}-containers.img.xz"
+SRC_URI[md5sum] = "8d6003d6e44a5278d57367b7000d97da"
+SRC_URI[sha256sum] = "1a78b0a1e43552528a820ff6f7eaf3f3fb15b2d71b629eb103911f10b15b449f"
+
+FILES_${PN} += "/usr/share/clear-containers/*"
+
+do_install_append () {
+ cd ${WORKDIR} ; rm -f clear-containers.img
+ ln -s clear-${PV}-containers.img clear-containers.img
+ mkdir -p ${D}/usr/share/clear-containers/
+ cp -rf ${WORKDIR}/clear*-containers.img ${D}/usr/share/clear-containers/
+}
diff --git a/recipes-devtools/cc-oci-artifacts/cc-kernel_4.9.33-74.bb b/recipes-devtools/cc-oci-artifacts/cc-kernel_4.9.33-74.bb
new file mode 100644
index 0000000..5d03ffb
--- /dev/null
+++ b/recipes-devtools/cc-oci-artifacts/cc-kernel_4.9.33-74.bb
@@ -0,0 +1,19 @@
+SUMMARY = "The Linux kernel optimized for running inside a container"
+DESCRIPTION = "The Linux kernel."
+HOMEPAGE = "http://www.kernel.org/"
+
+LICENSE = "GPLv2"
+ERROR_QA_remove = "license-checksum"
+
+SRC_URI = "http://download.clearlinux.org/releases/16050/clear/x86_64/os/Packages/linux-container-${PV}.x86_64.rpm"
+SRC_URI[md5sum] = "69f268d45c3dfee82f1afbd479534e08"
+SRC_URI[sha256sum] = "0f915e1b18ddcdd13fb339d3cc7b9857297dd1340f69dde504012f3e644c4293"
+
+FILES_${PN} += "/usr/share/clear-containers/*"
+
+do_unpack[depends] += "xz-native:do_populate_sysroot"
+
+do_install_append () {
+ cp -rf ${WORKDIR}/usr ${D}/usr
+}
+
diff --git a/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch b/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch
new file mode 100644
index 0000000..e867d02
--- /dev/null
+++ b/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch
@@ -0,0 +1,26 @@
+From ae42e6f3516b322d6bca9b82f6c4a64cad37024a Mon Sep 17 00:00:00 2001
+From: Todor Minchev <todor.minchev@linux.intel.com>
+Date: Mon, 28 Aug 2017 14:41:56 -0700
+Subject: [PATCH] configure.ac: set defaul qemu patch to /usr/local/bin
+
+Signed-off-by: Todor Minchev <todor.minchev@linux.intel.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 44292af..bb03068 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -212,7 +212,7 @@ AC_ARG_WITH([cc-image-bootchart-config-dir],
+ AM_CONDITIONAL([CC_IMAGE_BOOTCHART_CONFIG],[test x"$WITH_CC_IMAGE_BOOTCHART_CONFIG" != xno])
+
+ #Check for qemu
+-DEFAULT_QEMU_PATH=/usr/bin/qemu-system-x86_64
++DEFAULT_QEMU_PATH=/usr/local/bin/qemu-system-x86_64
+
+ AC_ARG_WITH([qemu-path],
+ [AS_HELP_STRING([--with-qemu-path=[[QEMU-PATH]]],
+--
+2.13.2
+
diff --git a/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-hypervisor.in-set-default-machine-to-q35.patch b/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-hypervisor.in-set-default-machine-to-q35.patch
new file mode 100644
index 0000000..c4da06d
--- /dev/null
+++ b/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-hypervisor.in-set-default-machine-to-q35.patch
@@ -0,0 +1,26 @@
+From ae7006fbd25a243a83f35d5372a02ca34e05ba3a Mon Sep 17 00:00:00 2001
+From: Todor Minchev <todor.minchev@linux.intel.com>
+Date: Mon, 28 Aug 2017 15:07:54 -0700
+Subject: [PATCH] hypervisor.in: set default machine to q35
+
+Signed-off-by: Todor Minchev <todor.minchev@linux.intel.com>
+---
+ data/hypervisor.args.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/data/hypervisor.args.in b/data/hypervisor.args.in
+index b96016b..7095503 100644
+--- a/data/hypervisor.args.in
++++ b/data/hypervisor.args.in
+@@ -2,7 +2,7 @@
+ -name
+ @NAME@
+ -machine
+-pc-lite,accel=kvm,kernel_irqchip,nvdimm
++q35,accel=kvm,kernel_irqchip,nvdimm,nosmm,nosmbus,nosata,nopit,nofw
+ -device
+ nvdimm,memdev=mem0,id=nv0
+ -object
+--
+2.13.2
+
diff --git a/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb b/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb
new file mode 100644
index 0000000..4e63748
--- /dev/null
+++ b/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb
@@ -0,0 +1,37 @@
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+inherit systemd
+SYSTEMD_SERVICE_${PN} = "cc-proxy.service"
+
+SRC_URI = "git://git@github.com/01org/cc-oci-runtime.git;protocol=https \
+ file://0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch \
+ file://0001-hypervisor.in-set-default-machine-to-q35.patch \
+ "
+
+SRCREV = "fdce5d7c941c0af3a2b18246c62cabf890e7664f"
+
+DISABLE_STATIC = ""
+PACKAGECONFIG_CONFARGS = " "
+
+RDEPENDS_${PN} = "qemu-cc cc-image cc-kernel tunctl docker docker-contrib connman connman-client"
+DEPENDS = " autoconf-archive-native gnome-common go-native json-glib libcheck libmnl util-linux glib-2.0"
+QEMU_CC_MEM ?= "256M,slots=2,maxmem=1G"
+
+S = "${WORKDIR}/git"
+FILES_${PN} += "/lib/systemd/system/* \
+ /usr/share/defaults/* "
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = " --disable-valgrind-sgcheck --disable-functional-tests --enable-autogopath --disable-docker-tests --disable-metrics-tests --disable-crio-tests --disable-valgrind-drd"
+
+do_configure_append() {
+ cp -rfp ${S}/vendor ${S}/../build/
+ cp -rfp ${S}/proxy ${S}/../build/
+ sed -i -e "s/^2G,slots=2,maxmem=3G/${QEMU_CC_MEM}/" ${S}/../build/data/hypervisor.args
+}
+
+do_compile() {
+ oe_runmake
+}
diff --git a/recipes-devtools/qemu-cc/qemu-cc.bb b/recipes-devtools/qemu-cc/qemu-cc.bb
new file mode 100644
index 0000000..b9b2d8a
--- /dev/null
+++ b/recipes-devtools/qemu-cc/qemu-cc.bb
@@ -0,0 +1,85 @@
+SUMMARY = "Fast open source processor emulator"
+HOMEPAGE = "https://github.com/clearcontainers/qemu"
+LICENSE = "GPLv2 & LGPLv2.1"
+DEPENDS = "zlib libcap-ng glib-2.0 pixman attr libcap"
+
+DISABLE_STATIC = ""
+inherit pkgconfig
+
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=79ffa0ec772fa86740948cb7327a0cc7 \
+ file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac"
+
+SRC_URI = "gitsm://github.com/clearcontainers/qemu.git;protocol=https;branch=qemu-lite-v2.9.0"
+
+PV = "2.9"
+SRCREV = "a2e6957b6fcbf9be3c5146657ba9ae1dddf3ec70"
+
+S = "${WORKDIR}/git"
+FILES_${PN} += "/usr/local/* \
+ /usr/var/* "
+INSANE_SKIP_${PN} = "already-stripped"
+
+EXTRA_OECONF = " \
+ --disable-tools \
+ --disable-libssh2 \
+ --disable-tcmalloc \
+ --disable-glusterfs \
+ --disable-seccomp \
+ --disable-bzip2 \
+ --disable-snappy \
+ --disable-lzo \
+ --disable-usb-redir \
+ --disable-libusb \
+ --disable-libnfs \
+ --disable-tcg-interpreter \
+ --disable-debug-tcg \
+ --disable-libiscsi \
+ --disable-rbd \
+ --disable-spice \
+ --disable-attr \
+ --disable-cap-ng \
+ --disable-linux-aio \
+ --disable-brlapi \
+ --disable-vnc-jpeg \
+ --disable-vnc-png \
+ --disable-vnc-sasl \
+ --disable-rdma \
+ --disable-bluez \
+ --disable-fdt \
+ --disable-curl \
+ --disable-curses \
+ --disable-sdl \
+ --disable-gtk \
+ --disable-tpm \
+ --disable-vte \
+ --disable-vnc \
+ --disable-xen \
+ --disable-opengl \
+ --disable-slirp \
+ --disable-strip \
+ --enable-trace-backend=nop \
+ --enable-virtfs \
+ --enable-attr \
+ --enable-cap-ng \
+ --extra-cflags=-Wno-format-truncation \
+ --extra-cflags=-Wno-maybe-uninitialized \
+ --prefix=/usr/local \
+ --target-list=x86_64-softmmu "
+
+do_configure() {
+ ${S}/configure ${EXTRA_OECONF}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR='${D}'
+ rm -rf ${D}/usr/local/share/qemu/openbios-ppc
+ rm -rf ${D}/usr/local/share/qemu/openbios-sparc32
+ rm -rf ${D}/usr/local/share/qemu/openbios-sparc64
+ rm -rf ${D}/usr/local/share/qemu/s390-ccw.img
+ rm -rf ${D}/usr/local/share/qemu/palcode-clipper
+ rm -rf ${D}/usr/local/share/qemu/u-boot.e500
+}