aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/cc-oci-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/cc-oci-runtime')
-rw-r--r--recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch26
-rw-r--r--recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-hypervisor.in-set-default-machine-to-q35.patch26
-rw-r--r--recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb37
3 files changed, 89 insertions, 0 deletions
diff --git a/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch b/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch
new file mode 100644
index 0000000..e867d02
--- /dev/null
+++ b/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch
@@ -0,0 +1,26 @@
+From ae42e6f3516b322d6bca9b82f6c4a64cad37024a Mon Sep 17 00:00:00 2001
+From: Todor Minchev <todor.minchev@linux.intel.com>
+Date: Mon, 28 Aug 2017 14:41:56 -0700
+Subject: [PATCH] configure.ac: set defaul qemu patch to /usr/local/bin
+
+Signed-off-by: Todor Minchev <todor.minchev@linux.intel.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 44292af..bb03068 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -212,7 +212,7 @@ AC_ARG_WITH([cc-image-bootchart-config-dir],
+ AM_CONDITIONAL([CC_IMAGE_BOOTCHART_CONFIG],[test x"$WITH_CC_IMAGE_BOOTCHART_CONFIG" != xno])
+
+ #Check for qemu
+-DEFAULT_QEMU_PATH=/usr/bin/qemu-system-x86_64
++DEFAULT_QEMU_PATH=/usr/local/bin/qemu-system-x86_64
+
+ AC_ARG_WITH([qemu-path],
+ [AS_HELP_STRING([--with-qemu-path=[[QEMU-PATH]]],
+--
+2.13.2
+
diff --git a/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-hypervisor.in-set-default-machine-to-q35.patch b/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-hypervisor.in-set-default-machine-to-q35.patch
new file mode 100644
index 0000000..c4da06d
--- /dev/null
+++ b/recipes-devtools/cc-oci-runtime/cc-oci-runtime/0001-hypervisor.in-set-default-machine-to-q35.patch
@@ -0,0 +1,26 @@
+From ae7006fbd25a243a83f35d5372a02ca34e05ba3a Mon Sep 17 00:00:00 2001
+From: Todor Minchev <todor.minchev@linux.intel.com>
+Date: Mon, 28 Aug 2017 15:07:54 -0700
+Subject: [PATCH] hypervisor.in: set default machine to q35
+
+Signed-off-by: Todor Minchev <todor.minchev@linux.intel.com>
+---
+ data/hypervisor.args.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/data/hypervisor.args.in b/data/hypervisor.args.in
+index b96016b..7095503 100644
+--- a/data/hypervisor.args.in
++++ b/data/hypervisor.args.in
+@@ -2,7 +2,7 @@
+ -name
+ @NAME@
+ -machine
+-pc-lite,accel=kvm,kernel_irqchip,nvdimm
++q35,accel=kvm,kernel_irqchip,nvdimm,nosmm,nosmbus,nosata,nopit,nofw
+ -device
+ nvdimm,memdev=mem0,id=nv0
+ -object
+--
+2.13.2
+
diff --git a/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb b/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb
new file mode 100644
index 0000000..4e63748
--- /dev/null
+++ b/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb
@@ -0,0 +1,37 @@
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+inherit systemd
+SYSTEMD_SERVICE_${PN} = "cc-proxy.service"
+
+SRC_URI = "git://git@github.com/01org/cc-oci-runtime.git;protocol=https \
+ file://0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch \
+ file://0001-hypervisor.in-set-default-machine-to-q35.patch \
+ "
+
+SRCREV = "fdce5d7c941c0af3a2b18246c62cabf890e7664f"
+
+DISABLE_STATIC = ""
+PACKAGECONFIG_CONFARGS = " "
+
+RDEPENDS_${PN} = "qemu-cc cc-image cc-kernel tunctl docker docker-contrib connman connman-client"
+DEPENDS = " autoconf-archive-native gnome-common go-native json-glib libcheck libmnl util-linux glib-2.0"
+QEMU_CC_MEM ?= "256M,slots=2,maxmem=1G"
+
+S = "${WORKDIR}/git"
+FILES_${PN} += "/lib/systemd/system/* \
+ /usr/share/defaults/* "
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = " --disable-valgrind-sgcheck --disable-functional-tests --enable-autogopath --disable-docker-tests --disable-metrics-tests --disable-crio-tests --disable-valgrind-drd"
+
+do_configure_append() {
+ cp -rfp ${S}/vendor ${S}/../build/
+ cp -rfp ${S}/proxy ${S}/../build/
+ sed -i -e "s/^2G,slots=2,maxmem=3G/${QEMU_CC_MEM}/" ${S}/../build/data/hypervisor.args
+}
+
+do_compile() {
+ oe_runmake
+}