aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb')
-rw-r--r--recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb b/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb
new file mode 100644
index 0000000..4e63748
--- /dev/null
+++ b/recipes-devtools/cc-oci-runtime/cc-oci-runtime_git.bb
@@ -0,0 +1,37 @@
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+inherit systemd
+SYSTEMD_SERVICE_${PN} = "cc-proxy.service"
+
+SRC_URI = "git://git@github.com/01org/cc-oci-runtime.git;protocol=https \
+ file://0001-configure.ac-set-defaul-qemu-patch-to-usr-local-bin.patch \
+ file://0001-hypervisor.in-set-default-machine-to-q35.patch \
+ "
+
+SRCREV = "fdce5d7c941c0af3a2b18246c62cabf890e7664f"
+
+DISABLE_STATIC = ""
+PACKAGECONFIG_CONFARGS = " "
+
+RDEPENDS_${PN} = "qemu-cc cc-image cc-kernel tunctl docker docker-contrib connman connman-client"
+DEPENDS = " autoconf-archive-native gnome-common go-native json-glib libcheck libmnl util-linux glib-2.0"
+QEMU_CC_MEM ?= "256M,slots=2,maxmem=1G"
+
+S = "${WORKDIR}/git"
+FILES_${PN} += "/lib/systemd/system/* \
+ /usr/share/defaults/* "
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = " --disable-valgrind-sgcheck --disable-functional-tests --enable-autogopath --disable-docker-tests --disable-metrics-tests --disable-crio-tests --disable-valgrind-drd"
+
+do_configure_append() {
+ cp -rfp ${S}/vendor ${S}/../build/
+ cp -rfp ${S}/proxy ${S}/../build/
+ sed -i -e "s/^2G,slots=2,maxmem=3G/${QEMU_CC_MEM}/" ${S}/../build/data/hypervisor.args
+}
+
+do_compile() {
+ oe_runmake
+}