aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/cc-oci-artifacts
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/cc-oci-artifacts')
-rw-r--r--recipes-devtools/cc-oci-artifacts/cc-image_16050.bb15
-rw-r--r--recipes-devtools/cc-oci-artifacts/cc-kernel_4.9.33-74.bb19
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-devtools/cc-oci-artifacts/cc-image_16050.bb b/recipes-devtools/cc-oci-artifacts/cc-image_16050.bb
new file mode 100644
index 0000000..1849e94
--- /dev/null
+++ b/recipes-devtools/cc-oci-artifacts/cc-image_16050.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPLv2"
+ERROR_QA_remove = "license-checksum"
+
+SRC_URI = "https://download.clearlinux.org/releases/16050/clear/clear-${PV}-containers.img.xz"
+SRC_URI[md5sum] = "8d6003d6e44a5278d57367b7000d97da"
+SRC_URI[sha256sum] = "1a78b0a1e43552528a820ff6f7eaf3f3fb15b2d71b629eb103911f10b15b449f"
+
+FILES_${PN} += "/usr/share/clear-containers/*"
+
+do_install_append () {
+ cd ${WORKDIR} ; rm -f clear-containers.img
+ ln -s clear-${PV}-containers.img clear-containers.img
+ mkdir -p ${D}/usr/share/clear-containers/
+ cp -rf ${WORKDIR}/clear*-containers.img ${D}/usr/share/clear-containers/
+}
diff --git a/recipes-devtools/cc-oci-artifacts/cc-kernel_4.9.33-74.bb b/recipes-devtools/cc-oci-artifacts/cc-kernel_4.9.33-74.bb
new file mode 100644
index 0000000..5d03ffb
--- /dev/null
+++ b/recipes-devtools/cc-oci-artifacts/cc-kernel_4.9.33-74.bb
@@ -0,0 +1,19 @@
+SUMMARY = "The Linux kernel optimized for running inside a container"
+DESCRIPTION = "The Linux kernel."
+HOMEPAGE = "http://www.kernel.org/"
+
+LICENSE = "GPLv2"
+ERROR_QA_remove = "license-checksum"
+
+SRC_URI = "http://download.clearlinux.org/releases/16050/clear/x86_64/os/Packages/linux-container-${PV}.x86_64.rpm"
+SRC_URI[md5sum] = "69f268d45c3dfee82f1afbd479534e08"
+SRC_URI[sha256sum] = "0f915e1b18ddcdd13fb339d3cc7b9857297dd1340f69dde504012f3e644c4293"
+
+FILES_${PN} += "/usr/share/clear-containers/*"
+
+do_unpack[depends] += "xz-native:do_populate_sysroot"
+
+do_install_append () {
+ cp -rf ${WORKDIR}/usr ${D}/usr
+}
+