aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/mc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/mc')
-rw-r--r--recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch52
-rw-r--r--recipes-extended/mc/mc_4.7.5.2.bb31
2 files changed, 67 insertions, 16 deletions
diff --git a/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch b/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch
new file mode 100644
index 0000000..dbf18ca
--- /dev/null
+++ b/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch
@@ -0,0 +1,52 @@
+From 56aef108be94019c7828c14f0c4849336f811847 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 17 Dec 2019 16:34:06 +0100
+Subject: [PATCH] Fix builds wit the gettext 0.20
+
+Upstream-Status: Inappropriate [fixing an old version]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ src/Makefile.am | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index ab4f9b7..b27ab4a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to create Makefile.in.
+ AUTOMAKE_OPTIONS = 1.5
+
+-SUBDIRS = intl po lib src doc contrib misc
++SUBDIRS = po lib src doc contrib misc
+
+ EXTRA_DIST =
+
+diff --git a/configure.ac b/configure.ac
+index c05902d..0430714 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -88,7 +88,7 @@ fi
+ dnl
+ dnl Internationalization
+ dnl
+-AM_GNU_GETTEXT(no-libtool, need-ngettext)
++AM_GNU_GETTEXT([external],no-libtool, need-ngettext)
+ AM_GNU_GETTEXT_VERSION(0.14.3)
+
+ if test "x$USE_INCLUDED_LIBINTL" = xyes; then
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 2da86c3..1859f0d 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -52,7 +52,7 @@ else
+ mc_LDADD += $(GLIB_LIBS)
+ endif
+
+-mc_LDADD += $(PCRE_LIBS) $(LIBICONV) $(INTLLIBS)
++mc_LDADD += $(PCRE_LIBS) $(INTLLIBS)
+
+ SRC_mc_conssaver = \
+ cons.handler.c consaver/cons.saver.h
diff --git a/recipes-extended/mc/mc_4.7.5.2.bb b/recipes-extended/mc/mc_4.7.5.2.bb
index ca84966..0fe4ab0 100644
--- a/recipes-extended/mc/mc_4.7.5.2.bb
+++ b/recipes-extended/mc/mc_4.7.5.2.bb
@@ -1,16 +1,17 @@
SUMMARY = "Midnight Commander is an ncurses based file manager"
HOMEPAGE = "http://www.midnight-commander.org/"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
SECTION = "console/utils"
DEPENDS = "ncurses glib-2.0"
-RDEPENDS_${PN} = "ncurses-terminfo"
+RDEPENDS:${PN} = "ncurses-terminfo"
PR = "r3"
SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
file://mc-CTRL.patch \
file://0001-disable-Ctrl-g-key-and-Ctrl-key.patch \
+ file://0001-Fix-builds-wit-the-gettext-0.20.patch \
"
SRC_URI[md5sum] = "bdae966244496cd4f6d282d80c9cf3c6"
@@ -20,29 +21,27 @@ inherit autotools gettext pkgconfig
EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-samba"
-do_install_append () {
+do_install:append () {
sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
- sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
+ # These use python2 which is no longer supported
+ rm ${D}${libexecdir}/mc/extfs.d/s3+
+ rm ${D}${libexecdir}/mc/extfs.d/uc1541
}
-PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
+PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
-SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
-FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
+SUMMARY:${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
+FILES:${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
${libexecdir}/mc/extfs.d/uzip"
-RDEPENDS_${BPN}-helpers-perl = "perl"
+RDEPENDS:${BPN}-helpers-perl = "perl"
-SUMMARY_${BPN}-helpers-python = "Midnight Commander Python-based helper scripts"
-FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
-RDEPENDS_${BPN}-helpers-python = "python"
+SUMMARY:${BPN}-helpers = "Midnight Commander shell helper scripts"
+FILES:${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
-SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
-FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
-
-SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
-FILES_${BPN}-fish = "${libexecdir}/mc/fish"
+SUMMARY:${BPN}-fish = "Midnight Commander Fish scripts"
+FILES:${BPN}-fish = "${libexecdir}/mc/fish"