aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/gzip
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/gzip')
-rw-r--r--recipes-extended/gzip/gzip.inc8
-rw-r--r--recipes-extended/gzip/gzip_1.3.12.bb2
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-extended/gzip/gzip.inc b/recipes-extended/gzip/gzip.inc
index 04f8f95..15fd665 100644
--- a/recipes-extended/gzip/gzip.inc
+++ b/recipes-extended/gzip/gzip.inc
@@ -8,10 +8,10 @@ SECTION = "console/utils"
inherit autotools texinfo
export DEFS="NO_ASM"
-EXTRA_OEMAKE_class-target = "GREP=${base_bindir}/grep"
-EXTRA_OECONF_append_libc-musl = " gl_cv_func_fflush_stdin=yes "
+EXTRA_OEMAKE:class-target = "GREP=${base_bindir}/grep"
+EXTRA_OECONF:append:libc-musl = " gl_cv_func_fflush_stdin=yes "
-do_install_append () {
+do_install:append () {
if [ "${base_bindir}" != "${bindir}" ]; then
# Rename and move files into /bin (FHS), which is typical place for gzip
install -d ${D}${base_bindir}
@@ -25,7 +25,7 @@ do_install_append () {
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"
-ALTERNATIVE_${PN} = "gunzip gzip zcat"
+ALTERNATIVE:${PN} = "gunzip gzip zcat"
ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
diff --git a/recipes-extended/gzip/gzip_1.3.12.bb b/recipes-extended/gzip/gzip_1.3.12.bb
index 5f7f6cd..94998ca 100644
--- a/recipes-extended/gzip/gzip_1.3.12.bb
+++ b/recipes-extended/gzip/gzip_1.3.12.bb
@@ -1,6 +1,6 @@
require gzip.inc
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://gzip.h;endline=22;md5=c0934ad1900d927f86556153d4c76d23 \
file://lzw.h;endline=19;md5=c273e09a02edd9801cc74d39683049e9 "