aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-05 11:23:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-05 11:35:38 +0100
commitfe935352291cfb498fd26252aa49cab7fc03d8ce (patch)
tree46425e3046ed1af41848aaa013f9b686c2313e9d
parente449dd1c9ee347fbfa36d9d787c8f7547fba5931 (diff)
downloadmeta-gplv2-fe935352291cfb498fd26252aa49cab7fc03d8ce.tar.gz
meta-gplv2-fe935352291cfb498fd26252aa49cab7fc03d8ce.tar.bz2
meta-gplv2-fe935352291cfb498fd26252aa49cab7fc03d8ce.zip
disable-gplv3.inc: Disable glib-2.0 ptest python3-dbusmock dependency
The newly added dependency on python3-dbusmock in OE-Core is GPLv3 and would fail to work with this layer. Remove it in the config for enabling the layer. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--conf/distro/include/disable-gplv3.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/conf/distro/include/disable-gplv3.inc b/conf/distro/include/disable-gplv3.inc
index 45834b7..761be7d 100644
--- a/conf/distro/include/disable-gplv3.inc
+++ b/conf/distro/include/disable-gplv3.inc
@@ -1,2 +1,3 @@
INCOMPATIBLE_LICENSE = '*GPLv3'
WARN_QA_remove = 'incompatible-license'
+RDEPENDS_${PN}-ptest_remove_pn-glib-2.0 = "python3-dbusmock"