aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-tools/lxc/lxc_0.8.0-rc1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-tools/lxc/lxc_0.8.0-rc1.bb')
-rw-r--r--recipes-tools/lxc/lxc_0.8.0-rc1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-tools/lxc/lxc_0.8.0-rc1.bb b/recipes-tools/lxc/lxc_0.8.0-rc1.bb
new file mode 100644
index 0000000..d5e145f
--- /dev/null
+++ b/recipes-tools/lxc/lxc_0.8.0-rc1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "lxc aims to use these new functionnalities to provide an userspace container object"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+PRIORITY = "optional"
+DEPENDS = "libxml2 libcap"
+RDEPENDS_${PN} = " \
+ rsync \
+ gzip \
+ libcap-bin \
+ perl-module-strict \
+ perl-module-getopt-long \
+ perl-module-vars \
+ perl-module-warnings-register \
+ perl-module-exporter \
+ perl-module-constant \
+ perl-module-overload \
+ perl-module-exporter-heavy \
+"
+
+SRC_URI = "http://lxc.sourceforge.net/download/lxc/${PN}-${PV}.tar.gz \
+ file://noldconfig.patch \
+ "
+
+SRC_URI[md5sum] ="06ceecf4dbe1be988fc903ad8dd34d29"
+SRC_URI[sha256sum] = "32bf83902c07387646c55de440d6d12cf61bd54c97417109c2d1ac47d17cb911"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+EXTRA_OECONF = "--disable-doc --disable-rpath"
+
+inherit autotools
+
+FILES_${PN}-dbg += "${libexecdir}/lxc/.debug"