aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/lttng/lttng-modules_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/lttng/lttng-modules_%.bbappend')
-rw-r--r--recipes-kernel/lttng/lttng-modules_%.bbappend18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/lttng/lttng-modules_%.bbappend b/recipes-kernel/lttng/lttng-modules_%.bbappend
new file mode 100644
index 0000000..5415f16
--- /dev/null
+++ b/recipes-kernel/lttng/lttng-modules_%.bbappend
@@ -0,0 +1,18 @@
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES_append_e6500 ?= "multiarch"
+
+python () {
+
+ promote_kernel = d.getVar('BUILD_64BIT_KERNEL')
+
+ if promote_kernel == "1":
+ d.appendVar('KERNEL_CC', ' -m64')
+ d.appendVar('KERNEL_LD', ' -melf64ppc')
+
+
+ error_qa = d.getVar('ERROR_QA', True)
+ if 'arch' in error_qa:
+ d.setVar('ERROR_QA', error_qa.replace(' arch', ''))
+
+}