aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
new file mode 100644
index 0000000..a60ea98
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
@@ -0,0 +1,21 @@
+require cryptodev-qoriq_${PV}.inc
+
+SUMMARY = "A test suite for /dev/crypto device driver"
+DEPENDS = "openssl"
+
+PROVIDES = "cryptodev-tests"
+
+EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
+
+do_compile() {
+ oe_runmake testprogs
+}
+
+do_install() {
+ oe_runmake install_tests
+}
+
+FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
+FILES_${PN} = "${bindir}/tests_cryptodev/*"
+
+COMPATIBLE_MACHINE = "(qoriq)"