aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/rcw/rcw_git.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index ffdb547..41a0bbe 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -1,18 +1,18 @@
SUMMARY = "Reset Configuration Word"
DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
-LICENSE = "BSD"
-PR = "r8"
+LICENSE = "Freescale-EULA"
+LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
-inherit deploy
+inherit deploy siteinfo
-SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v1.9.x"
-SRCREV = "521008fe6ec9897fe245e1c1241fc27dad98f24d"
+SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x"
+SRCREV = "1af724b64347170e9d9ba8e8f277dd30026a1a7e"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/"
+EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','').replace('-${SITEINFO_ENDIANNESS}','')} DESTDIR=${D}/boot/rcw/"
do_install () {
oe_runmake install
@@ -24,6 +24,13 @@ do_install_append_ls102xa () {
done
}
+do_install_append_fsl-lsch2 () {
+ for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do
+ f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'`
+ tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8
+ done
+}
+
do_deploy () {
install -d ${DEPLOYDIR}/rcw
cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/