aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/pme-tools/files/0001-pme-tools-fix-build-error.patch127
-rw-r--r--recipes-extended/pme-tools/pme-tools_git.bb33
2 files changed, 160 insertions, 0 deletions
diff --git a/recipes-extended/pme-tools/files/0001-pme-tools-fix-build-error.patch b/recipes-extended/pme-tools/files/0001-pme-tools-fix-build-error.patch
new file mode 100644
index 0000000..5839d72
--- /dev/null
+++ b/recipes-extended/pme-tools/files/0001-pme-tools-fix-build-error.patch
@@ -0,0 +1,127 @@
+From 576218f3a173dcd8b68b7c247612d1b585906742 Mon Sep 17 00:00:00 2001
+From: Zhenhua Luo <zhenhua.luo@nxp.com>
+Date: Wed, 13 Jan 2016 04:07:12 -0600
+Subject: [PATCH] pme-tools: fix build error
+
+Fix the following build error:
+| *.y: error: expected ';' before '}' token
+
+Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
+---
+ compilers/regularExpression/engine/pmrec.y | 6 ++--
+ compilers/statefulRule/engine/pmsrc.y | 46 ++++++++++++++--------------
+ 2 files changed, 26 insertions(+), 26 deletions(-)
+
+diff --git a/compilers/regularExpression/engine/pmrec.y b/compilers/regularExpression/engine/pmrec.y
+index ececd81..a9bed4b 100644
+--- a/compilers/regularExpression/engine/pmrec.y
++++ b/compilers/regularExpression/engine/pmrec.y
+@@ -2939,7 +2939,7 @@ input : /* empty */
+ | end_of_lines
+ | input regex
+ | input error
+- {return(pmrec_syntax_error_e)}
++ {return(pmrec_syntax_error_e);}
+ ;
+
+ regex : start_regex branches end_regex
+@@ -3324,9 +3324,9 @@ one_character_regex : non_meta_character
+ ;
+
+ non_meta_characters : non_meta_character
+- {_pmrec_context_p->currentPattern_p->blockAnchorNumSymbols++}
++ {_pmrec_context_p->currentPattern_p->blockAnchorNumSymbols++;}
+ | non_meta_characters non_meta_character
+- {_pmrec_context_p->currentPattern_p->blockAnchorNumSymbols++}
++ {_pmrec_context_p->currentPattern_p->blockAnchorNumSymbols++;}
+ ;
+
+ non_meta_character : alpha
+diff --git a/compilers/statefulRule/engine/pmsrc.y b/compilers/statefulRule/engine/pmsrc.y
+index 513e22f..0bc4d6a 100644
+--- a/compilers/statefulRule/engine/pmsrc.y
++++ b/compilers/statefulRule/engine/pmsrc.y
+@@ -6361,45 +6361,45 @@ state_definitions : state_definition
+ ;
+
+ reserved_word : RULE_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | RESET_ON_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | RESET_STATE_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | EVENT_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | STATE_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | NEXT_STATE_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | EXIT_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | GPRV
+- {$$ = $1}
++ {$$ = $1;}
+ | TEMP_GPRV
+- {$$ = $1}
++ {$$ = $1;}
+ | GLOBAL_GPRV
+- {$$ = $1}
++ {$$ = $1;}
+ | FLAG
+- {$$ = $1}
++ {$$ = $1;}
+ | VOLATILE_FLAG
+- {$$ = $1}
++ {$$ = $1;}
+ | REPORT_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | WRITE_LABEL
+- {$$ = $1}
++ {$$ = $1;}
+ | WHILE
+- {$$ = $1}
++ {$$ = $1;}
+ | BREAK
+- {$$ = $1}
++ {$$ = $1;}
+ | IF
+- {$$ = $1}
++ {$$ = $1;}
+ | ELSE
+- {$$ = $1}
++ {$$ = $1;}
+ | LOGICAL_AND
+- {$$ = $1}
++ {$$ = $1;}
+ | LOGICAL_OR
+- {$$ = $1}
++ {$$ = $1;}
+ | END_OF_SUI
+ {$$ = $1;
+ _pmsrc_parse_warning(_pmsrc_context_p,
+@@ -6408,11 +6408,11 @@ reserved_word : RULE_LABEL
+ }
+
+ no_keywords_name : NAME
+- {$$ = $1}
++ {$$ = $1;}
+ | DEC_NUM
+- {$$ = $1}
++ {$$ = $1;}
+ | HEX_NUM
+- {$$ = $1}
++ {$$ = $1;}
+ ;
+ any_name : no_keywords_name
+ | reserved_word
+--
+1.7.9.5
+
diff --git a/recipes-extended/pme-tools/pme-tools_git.bb b/recipes-extended/pme-tools/pme-tools_git.bb
new file mode 100644
index 0000000..e764153
--- /dev/null
+++ b/recipes-extended/pme-tools/pme-tools_git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Pattern matcher tools"
+LICENSE = "Freescale-EULA"
+LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/pme_tools.git;branch=sdk-v2.0.x \
+ file://0001-pme-tools-fix-build-error.patch \
+"
+SRCREV = "5b6622e127ac2f3e221cc0395985ac90e2ed9533"
+
+S = "${WORKDIR}/git"
+
+PARALLEL_MAKE = ""
+EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} USE_LTIB=1 LTIB_LIB_PATH=${STAGING_LIBDIR} SYSROOT=${STAGING_DIR_TARGET} CROSS_COMPILE=${HOST_PREFIX}"
+EXTRA_CFLAGS = "-Wno-unused-but-set-parameter -Wno-enum-compare -Wno-unused-but-set-variable"
+do_compile_prepend() {
+ sed -i '/rec_yyget_leng/d' compilers/regularExpression/engine/pmrec.lex
+ sed -i '/src_yyget_leng/d' compilers/statefulRule/engine/pmsrc.lex
+ sed -i '/srcPreproc_yyget_leng/d' compilers/statefulRule/engine/pmsrc_preproc.lex
+ oe_runmake clean
+}
+
+do_install() {
+ install -m 755 -d ${D}${bindir} -d ${D}${sbindir}
+ oe_runmake INSTALL_DIR=${D}/usr install
+
+ # add runtime support files
+ install -m 755 -d ${D}/${datadir}/pme-tools/sample_rules
+ install -m 644 ltib_supp/sample* ${D}/${datadir}/pme-tools/sample_rules
+ install -m 755 -d ${D}/etc/udev/rules.d
+ install -m 644 ltib_supp/06-fsl-pme-device.rules ${D}/etc/udev/rules.d
+}
+
+COMPATIBLE_MACHINE = "(e500mc|e5500|e5500-64b|e6500|e6500-64b)"