aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/002_Return_ERESTARTSYS_from_IPU_GET_EVENT.patch23
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/003_Sanitise_ipu_interrupt_return_value.patch50
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch32
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/mx23-do-not-use-safe-write.patch31
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/mx23-dont-mange-IRQ_VDDA_BRNOUT.patch51
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/no-unaligned-access.patch40
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch30
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Fix-build-against-newer-glibc.patch40
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb14
9 files changed, 3 insertions, 308 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/002_Return_ERESTARTSYS_from_IPU_GET_EVENT.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/002_Return_ERESTARTSYS_from_IPU_GET_EVENT.patch
deleted file mode 100644
index 08cf608..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/002_Return_ERESTARTSYS_from_IPU_GET_EVENT.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-commit 0ffabfea6c190d28e25587c95e282eb777b3feb2
-Author: Phil Endecott <git@chezphil.org>
-Date: Mon Oct 31 21:21:41 2011 +0000
-
- Return ERESTARTSYS from IPU_GET_EVENT
-
-Index: git/drivers/mxc/ipu/ipu_device.c
-===================================================================
---- git.orig/drivers/mxc/ipu/ipu_device.c 2012-01-24 15:34:37.000000000 +0100
-+++ git/drivers/mxc/ipu/ipu_device.c 2012-01-31 16:21:19.599303457 +0100
-@@ -411,8 +411,10 @@
-
- r = get_events(&info);
- if (r == -1) {
-- wait_event_interruptible_timeout(waitq,
-- (pending_events != 0), 2 * HZ);
-+ if (wait_event_interruptible_timeout(waitq,
-+ (pending_events != 0), 2 * HZ)) < 0) {
-+ return -ERESTARTSYS;
-+ }
- r = get_events(&info);
- }
- ret = -1;
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/003_Sanitise_ipu_interrupt_return_value.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/003_Sanitise_ipu_interrupt_return_value.patch
deleted file mode 100644
index c199959..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/003_Sanitise_ipu_interrupt_return_value.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-commit 7237ebd59bf1cd8bcc9508ec4bc5674dc7cc6c58
-Author: Phil Endecott <git@chezphil.org>
-Date: Tue Nov 1 18:16:56 2011 +0000
-
- Sanitise ipu interrupt return value, and loop waiting for interrupt
-
-diff --git a/drivers/mxc/ipu3/ipu_device.c b/drivers/mxc/ipu3/ipu_device.c
-index 1955f09..d66b8f8 100644
---- a/drivers/mxc/ipu3/ipu_device.c
-+++ b/drivers/mxc/ipu3/ipu_device.c
-@@ -311,7 +311,7 @@ static int mxc_ipu_ioctl(struct inode *inode, struct file *file,
- structure and pass the pointer in arg */
- {
- ipu_event_info info;
-- int r = -1;
-+ int r;
-
- if (copy_from_user
- (&info, (ipu_event_info *) arg,
-@@ -319,7 +319,7 @@ static int mxc_ipu_ioctl(struct inode *inode, struct file *file,
- return -EFAULT;
-
- r = get_events(&info);
-- if (r == -1) {
-+ while (r == -1) {
- if ((file->f_flags & O_NONBLOCK) &&
- (irq_info[info.irq].irq_pending == 0))
- return -EAGAIN;
-@@ -328,13 +328,15 @@ static int mxc_ipu_ioctl(struct inode *inode, struct file *file,
- return -ERESTARTSYS;
- }
- r = get_events(&info);
-+ if (r == -1) {
-+ /* Shouldn't happen? */
-+ printk(KERN_ERR "no events after waiting\n");
-+ }
- }
-- ret = -1;
-- if (r == 0) {
-- if (!copy_to_user((ipu_event_info *) arg,
-- &info, sizeof(ipu_event_info)))
-- ret = 0;
-- }
-+ if (copy_to_user((ipu_event_info *) arg,
-+ &info, sizeof(ipu_event_info)))
-+ return -EFAULT;
-+ ret = 0;
- }
- break;
- case IPU_ALOC_MEM:
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch
deleted file mode 100644
index 6a2a940..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-dm9601: Added support for usb ethernet (0x0fe6, 0x9700)
-
-The device is very similar to (0x0fe6, 0x8101),
-And works well with dm9601 driver.
-
-Upstream-Status: Backport [2.6.38]
-
-Signed-off-by: Shahar Havivi <shaharh@redhat.com>
-Acked-by: Peter Korsgaard <jacmet@sunsite.dk>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- drivers/net/usb/dm9601.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/drivers/net/usb/dm9601.c b/drivers/net/usb/dm9601.c
-index 02b622e..5002f5b 100644
---- a/drivers/net/usb/dm9601.c
-+++ b/drivers/net/usb/dm9601.c
-@@ -651,6 +651,10 @@ static const struct usb_device_id products[] = {
- .driver_info = (unsigned long)&dm9601_info,
- },
- {
-+ USB_DEVICE(0x0fe6, 0x9700), /* DM9601 USB to Fast Ethernet Adapter */
-+ .driver_info = (unsigned long)&dm9601_info,
-+ },
-+ {
- USB_DEVICE(0x0a46, 0x9000), /* DM9000E */
- .driver_info = (unsigned long)&dm9601_info,
- },
---
-1.7.10
-
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-do-not-use-safe-write.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-do-not-use-safe-write.patch
deleted file mode 100644
index d25a3ec..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-do-not-use-safe-write.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From: Otavio Salvador <otavio@ossystems.com.br>
-Subject: [PATCH 2/2] [MX23] Do not use safe write when building for MX23 arch
-
-The change 105ae4a60 include a safe write support for use with MX23
-but does not include a dummy implementation for other architecture
-making build to fail. This add a dummy version to allow the use with
-MX23 arch.
-
-Upstream-Status: Pending
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- arch/arm/plat-mxs/usb_common.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/arch/arm/plat-mxs/usb_common.c b/arch/arm/plat-mxs/usb_common.c
-index 700d168..c3bc9a9 100644
---- a/arch/arm/plat-mxs/usb_common.c
-+++ b/arch/arm/plat-mxs/usb_common.c
-@@ -53,6 +53,8 @@ static void fsl_safe_writel(u32 val32, volatile u32 *addr)
- {
- __asm__ ("swp %0, %0, [%1]" : : "r"(val32), "r"(addr));
- }
-+#else
-+static void fsl_safe_writel(u32 val32, volatile u32 *addr) { }
- #endif
-
- void fsl_usb_xcvr_register(struct fsl_xcvr_ops *xcvr_ops)
---
-1.7.10.4
-
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-dont-mange-IRQ_VDDA_BRNOUT.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-dont-mange-IRQ_VDDA_BRNOUT.patch
deleted file mode 100644
index a98878a..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-dont-mange-IRQ_VDDA_BRNOUT.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From: Otavio Salvador <otavio@ossystems.com.br>
-Subject: [PATCH 1/2] [MX23] Don't mangle IRQ_VDDA_BRNOUT for MX23 arch
-
-This has been introduced on commit e93820b3 and makes the kernel to
-fail to build for MX23 arch so we avoid the IRQ_VDDA_BRNOUT
-manipulation for MX23 arch as this IRQ is not available on MX23.
-
-Upstream-Status: Pending
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- drivers/power/mxs/linux.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/drivers/power/mxs/linux.c b/drivers/power/mxs/linux.c
-index d5185fa..0d6c729 100644
---- a/drivers/power/mxs/linux.c
-+++ b/drivers/power/mxs/linux.c
-@@ -1171,7 +1171,9 @@ static int __init mxs_bat_init(void)
- disable_irq(IRQ_DCDC4P2_BRNOUT);
- disable_irq(IRQ_BATT_BRNOUT);
- disable_irq(IRQ_VDDD_BRNOUT);
-+#ifndef CONFIG_ARCH_MX23
- disable_irq(IRQ_VDDA_BRNOUT);
-+#endif
- if (no_battery)
- disable_irq(IRQ_VDDIO_BRNOUT);
- #ifndef CONFIG_ARCH_MX28
-@@ -1184,7 +1186,9 @@ static int __init mxs_bat_init(void)
- mxs_set_irq_fiq(IRQ_DCDC4P2_BRNOUT, 1);
- mxs_set_irq_fiq(IRQ_BATT_BRNOUT, 1);
- mxs_set_irq_fiq(IRQ_VDDD_BRNOUT, 1);
-+#ifndef CONFIG_ARCH_MX23
- mxs_set_irq_fiq(IRQ_VDDA_BRNOUT, 1);
-+#endif
- if (no_battery)
- mxs_set_irq_fiq(IRQ_VDDIO_BRNOUT, 1);
- #ifndef CONFIG_ARCH_MX28
-@@ -1199,7 +1203,9 @@ static int __init mxs_bat_init(void)
- enable_irq(IRQ_DCDC4P2_BRNOUT);
- enable_irq(IRQ_BATT_BRNOUT);
- enable_irq(IRQ_VDDD_BRNOUT);
-+#ifndef CONFIG_ARCH_MX23
- enable_irq(IRQ_VDDA_BRNOUT);
-+#endif
- if (no_battery)
- enable_irq(IRQ_VDDIO_BRNOUT);
- #ifndef CONFIG_ARCH_MX28
---
-1.7.10.4
-
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/no-unaligned-access.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/no-unaligned-access.patch
deleted file mode 100644
index 23fe71e..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/no-unaligned-access.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 554683d..087e0c0 100644
---- a/Makefile
-+++ b/Makefile
-@@ -535,6 +535,9 @@ else
- KBUILD_CFLAGS += -O2
- endif
-
-+# conserve stack if available
-+KBUILD_CFLAGS += $(call cc-option,-fconserve-stack)
-+
- include $(srctree)/arch/$(SRCARCH)/Makefile
-
- ifneq ($(CONFIG_FRAME_WARN),0)
-@@ -579,9 +582,6 @@ KBUILD_CFLAGS += $(call cc-option,-Wno-pointer-sign,)
- # disable invalid "can't wrap" optimizations for signed / pointers
- KBUILD_CFLAGS += $(call cc-option,-fno-strict-overflow)
-
--# conserve stack if available
--KBUILD_CFLAGS += $(call cc-option,-fconserve-stack)
--
- # Add user supplied CPPFLAGS, AFLAGS and CFLAGS as the last assignments
- # But warn user when we do so
- warn-assign = \
-diff --git a/arch/arm/Makefile b/arch/arm/Makefile
-index 767874d..89afaea 100644
---- a/arch/arm/Makefile
-+++ b/arch/arm/Makefile
-@@ -93,6 +93,11 @@ ifeq ($(CONFIG_ARM_UNWIND),y)
- CFLAGS_ABI +=-funwind-tables
- endif
-
-+ifeq ($(CONFIG_ALIGNMENT_TRAP),y)
-+CFLAGS_ABI +=$(call cc-option,-mno-unaligned-access,)
-+endif
-+KBUILD_CFLAGS += $(call cc-option,-fno-conserve-stack,)
-+
- ifeq ($(CONFIG_THUMB2_KERNEL),y)
- AFLAGS_AUTOIT :=$(call as-option,-Wa$(comma)-mimplicit-it=always,-Wa$(comma)-mauto-it)
- AFLAGS_NOWARN :=$(call as-option,-Wa$(comma)-mno-warn-deprecated,-Wa$(comma)-W)
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch
deleted file mode 100644
index a22e45b..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From b4084d9ae7d8ac3d7fe01cc745836313ae73afb6 Mon Sep 17 00:00:00 2001
-From: Otavio Salvador <otavio@ossystems.com.br>
-Date: Fri, 7 Sep 2012 20:22:47 -0300
-Subject: [PATCH] perf tools: Do not treat warnings as errors
-
-Newer GCC detect more warnings and this makes building of perf not
-possible in the upcoming release of Yocto (1.3). We deal with that
-making the warnings not fatal instead of changing perf code.
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- tools/perf/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/perf/Makefile b/tools/perf/Makefile
-index d75c28a..854652a 100644
---- a/tools/perf/Makefile
-+++ b/tools/perf/Makefile
-@@ -225,7 +225,7 @@ ifndef PERF_DEBUG
- CFLAGS_OPTIMIZE = -O6
- endif
-
--CFLAGS = -ggdb3 -Wall -Wextra -std=gnu99 -Werror $(CFLAGS_OPTIMIZE) -D_FORTIFY_SOURCE=2 $(EXTRA_WARNINGS) $(EXTRA_CFLAGS)
-+CFLAGS = -ggdb3 -Wall -Wextra -std=gnu99 $(CFLAGS_OPTIMIZE) -D_FORTIFY_SOURCE=2 $(EXTRA_WARNINGS) $(EXTRA_CFLAGS)
- EXTLIBS = -lpthread -lrt -lelf -lm
- ALL_CFLAGS = $(CFLAGS) -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
- ALL_LDFLAGS = $(LDFLAGS)
---
-1.7.10.4
-
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Fix-build-against-newer-glibc.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Fix-build-against-newer-glibc.patch
deleted file mode 100644
index b90dfda..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Fix-build-against-newer-glibc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From ee7517dc33cd8c1d10bc504faef8a085694eebe2 Mon Sep 17 00:00:00 2001
-From: Josh Boyer <jwboyer@redhat.com>
-Date: Thu, 18 Aug 2011 07:37:21 -0400
-Subject: [PATCH 2/2] perf tools: Fix build against newer glibc
-
-Upstream glibc commit 295e904 added a definition for __attribute_const__
-to cdefs.h. This causes the following error when building perf:
-
-util/include/linux/compiler.h:8:0: error: "__attribute_const__"
-redefined [-Werror] /usr/include/sys/cdefs.h:226:0: note: this is the
-location of the previous definition
-
-Wrap __attribute_const__ in #ifndef as we do for __always_inline.
-
-Cc: Ingo Molnar <mingo@elte.hu>
-Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
-Link: http://lkml.kernel.org/r/20110818113720.GL2227@zod.bos.redhat.com
-Signed-off-by: Josh Boyer <jwboyer@redhat.com>
-Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
----
- tools/perf/util/include/linux/compiler.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/tools/perf/util/include/linux/compiler.h b/tools/perf/util/include/linux/compiler.h
-index 791f9dd..547628e 100644
---- a/tools/perf/util/include/linux/compiler.h
-+++ b/tools/perf/util/include/linux/compiler.h
-@@ -5,7 +5,9 @@
- #define __always_inline inline
- #endif
- #define __user
-+#ifndef __attribute_const__
- #define __attribute_const__
-+#endif
-
- #define __used __attribute__((__unused__))
-
---
-1.7.10.4
-
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index 4878259..083231e 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -1,31 +1,25 @@
# Copyright (C) 2011-2012 Freescale Semiconductor
# Released under the MIT license (see COPYING.MIT for the terms)
-PR = "${INC_PR}.7"
+PR = "${INC_PR}.8"
include linux-imx.inc
COMPATIBLE_MACHINE = "(mxs|mx5)"
# Revision of imx_2.6.35_10.12.01 branch
-SRCREV_mxs = "6a31a551bc302e74a17e9051bba356903e98273f"
+SRCREV_mxs = "38bf41cc376e24c384934fbeb10770d6712e9143"
LOCALVERSION = "-10.12.01+yocto-${DATE}"
# Revision of imx_2.6.35_11.09.01 branch
-SRCREV_mx5 = "cb0c4573ddf2eb4ee6942929f265560740f5dad2"
+SRCREV_mx5 = "406cab2e8b3c030c0f86263282f846bb55a2faf6"
LOCALVERSION = "-11.09.01+yocto-${DATE}"
SRC_URI += "file://NFS-Fix-nfsroot-support.patch \
file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \
- file://perf-tools-Fix-build-against-newer-glibc.patch \
- file://perf-tools-Do-not-treat-warnings-as-errors.patch \
- file://no-unaligned-access.patch \
- file://dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch \
"
SRC_URI_append_mxs = " \
- file://mx23-do-not-use-safe-write.patch \
- file://mx23-dont-mange-IRQ_VDDA_BRNOUT.patch \
file://mx28-removecpufreq.patch \
file://mxs-duart-use-ttyAMA-for-device-name.patch \
"
@@ -34,6 +28,4 @@ SRC_URI_append_mx5 = " \
file://mx5-fix-hang-with-framebuffer.patch \
file://egalax_ts-enable-single-event-support.patch \
file://0001-mx53_loco-add-USR-led-support.patch \
- file://002_Return_ERESTARTSYS_from_IPU_GET_EVENT.patch \
- file://003_Sanitise_ipu_interrupt_return_value.patch \
"