aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Allow-building-with-gcc-4.6.patch28
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Allow-building-with-gcc-4.6.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Allow-building-with-gcc-4.6.patch
new file mode 100644
index 0000000..ab14abf
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Allow-building-with-gcc-4.6.patch
@@ -0,0 +1,28 @@
+From 45e0440a7bf7b1549de7af0e6ce62fc0c73b4b51 Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Mon, 24 Sep 2012 09:02:31 -0300
+Subject: [PATCH] perf tools: Allow building with gcc 4.6
+
+The option -Wno-unused-but-set-variable has been add to EXTRA_WARNINGS
+to allow building with newer gcc versions.
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ tools/perf/Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tools/perf/Makefile b/tools/perf/Makefile
+index d75c28a..817872e 100644
+--- a/tools/perf/Makefile
++++ b/tools/perf/Makefile
+@@ -217,6 +217,7 @@ EXTRA_WARNINGS := $(EXTRA_WARNINGS) -Wnested-externs
+ EXTRA_WARNINGS := $(EXTRA_WARNINGS) -Wold-style-definition
+ EXTRA_WARNINGS := $(EXTRA_WARNINGS) -Wstrict-prototypes
+ EXTRA_WARNINGS := $(EXTRA_WARNINGS) -Wdeclaration-after-statement
++EXTRA_WARNINGS := $(EXTRA_WARNINGS) -Wno-unused-but-set-variable
+
+ ifeq ("$(origin DEBUG)", "command line")
+ PERF_DEBUG = $(DEBUG)
+--
+1.7.10.4
+
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index 68cc49f..739a632 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -1,7 +1,7 @@
# Copyright (C) 2011-2012 Freescale Semiconductor
# Released under the MIT license (see COPYING.MIT for the terms)
-PR = "${INC_PR}.10"
+PR = "${INC_PR}.11"
include linux-imx.inc
@@ -17,6 +17,7 @@ LOCALVERSION = "-11.09.01+yocto-${DATE}"
SRC_URI += "file://NFS-Fix-nfsroot-support.patch \
file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \
+ file://perf-tools-Allow-building-with-gcc-4.6.patch \
"
SRC_URI_append_mxs = " \