aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch30
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb3
2 files changed, 32 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch
new file mode 100644
index 0000000..a22e45b
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch
@@ -0,0 +1,30 @@
+From b4084d9ae7d8ac3d7fe01cc745836313ae73afb6 Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Fri, 7 Sep 2012 20:22:47 -0300
+Subject: [PATCH] perf tools: Do not treat warnings as errors
+
+Newer GCC detect more warnings and this makes building of perf not
+possible in the upcoming release of Yocto (1.3). We deal with that
+making the warnings not fatal instead of changing perf code.
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ tools/perf/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/perf/Makefile b/tools/perf/Makefile
+index d75c28a..854652a 100644
+--- a/tools/perf/Makefile
++++ b/tools/perf/Makefile
+@@ -225,7 +225,7 @@ ifndef PERF_DEBUG
+ CFLAGS_OPTIMIZE = -O6
+ endif
+
+-CFLAGS = -ggdb3 -Wall -Wextra -std=gnu99 -Werror $(CFLAGS_OPTIMIZE) -D_FORTIFY_SOURCE=2 $(EXTRA_WARNINGS) $(EXTRA_CFLAGS)
++CFLAGS = -ggdb3 -Wall -Wextra -std=gnu99 $(CFLAGS_OPTIMIZE) -D_FORTIFY_SOURCE=2 $(EXTRA_WARNINGS) $(EXTRA_CFLAGS)
+ EXTLIBS = -lpthread -lrt -lelf -lm
+ ALL_CFLAGS = $(CFLAGS) -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ ALL_LDFLAGS = $(LDFLAGS)
+--
+1.7.10.4
+
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index df11935..4878259 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -1,7 +1,7 @@
# Copyright (C) 2011-2012 Freescale Semiconductor
# Released under the MIT license (see COPYING.MIT for the terms)
-PR = "${INC_PR}.6"
+PR = "${INC_PR}.7"
include linux-imx.inc
@@ -18,6 +18,7 @@ LOCALVERSION = "-11.09.01+yocto-${DATE}"
SRC_URI += "file://NFS-Fix-nfsroot-support.patch \
file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \
file://perf-tools-Fix-build-against-newer-glibc.patch \
+ file://perf-tools-Do-not-treat-warnings-as-errors.patch \
file://no-unaligned-access.patch \
file://dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch \
"