aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_12.09.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_12.09.01.bb')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_12.09.01.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_12.09.01.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_12.09.01.bb
new file mode 100644
index 0000000..e319199
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_12.09.01.bb
@@ -0,0 +1,30 @@
+# Copyright (C) 2012 Freescale Semiconductor
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require recipes-graphics/xorg-driver/xorg-driver-video.inc
+
+DEPENDS += "virtual/libgal-x11 gpu-viv-bin-mx6q"
+
+LIC_FILES_CHKSUM = "file://src/vivante_fbdev/vivante.h;endline=19;md5=93a322f91ec495569dcbcfbb2a95454a"
+
+SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz \
+ file://Makefile.am-remove-prefixed-include-path.patch"
+SRC_URI[md5sum] = "1948119717aa01bed1f630be9ee7a708"
+SRC_URI[sha256sum] = "5b3be4b426d2d2803554df9e4d8919d1f9d17659c3153c71c6529f43c37e6ed1"
+
+EXTRA_OECONF_armv7a = " --enable-neon --disable-static"
+CFLAGS += " -I${STAGING_INCDIR}/xorg -I${STAGING_INCDIR}/drm"
+LDFLAGS += "-lm -ldl -lGAL-x11"
+
+S = "${WORKDIR}/xserver-xorg-video-imx-viv-${PV}"
+
+do_install_append () {
+ install -d ${D}${includedir}
+ cp -axr ${S}/src/vivante_gal/vivante_priv.h ${D}${includedir}
+ find ${D}${includedir} -type f -exec chmod 660 {} \;
+}
+
+RDEPENDS_${PN} += "xserver-xorg-module-exa"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mx6)"