aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston_%.bbappend')
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index b2f4466..f7bfd35 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -12,12 +12,19 @@ PACKAGECONFIG_append_mx6q = " cairo-glesv2"
PACKAGECONFIG_append_mx6dl = " cairo-glesv2"
PACKAGECONFIG_append_mx6sx = " cairo-glesv2"
PACKAGECONFIG_remove_mx6sl = "egl"
+PACKAGECONFIG_remove_mx6ul = "egl"
EXTRA_OECONF_append_mx6 = " \
--disable-libunwind \
--disable-xwayland-test \
WESTON_NATIVE_BACKEND=fbdev-backend.so \
"
+EXTRA_OECONF_append_mx6ul = " \
+ --disable-libunwind \
+ --disable-xwayland-test \
+ WESTON_NATIVE_BACKEND=fbdev-backend.so \
+"
+
EXTRA_OEMAKE_append_mx6 = " \
COMPOSITOR_CFLAGS="-I ${STAGING_INCDIR}/pixman-1 -DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \
FB_COMPOSITOR_CFLAGS="-DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \