aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston_%.bbappend')
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 0000000..0576b37
--- /dev/null
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,21 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0001-Add-support-for-Vivante-FBDEV-EGL.patch \
+ file://0002-weston-Add-Vivante-2D-compositor-support.patch "
+
+PACKAGECONFIG_mx6 = "fbdev egl cairo-glesv2"
+
+EXTRA_OECONF_append_mx6 = " \
+ --disable-libunwind \
+ --disable-xwayland-test \
+ WESTON_NATIVE_BACKEND=fbdev-backend.so \
+"
+
+EXTRA_OEMAKE_append_mx6 = " \
+ COMPOSITOR_LIBS="-lGLESv2 -lEGL -lGAL -lwayland-server -lxkbcommon -lpixman-1" \
+ COMPOSITOR_CFLAGS="-I ${STAGING_INCDIR}/pixman-1 -DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \
+ FB_COMPOSITOR_CFLAGS="-DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \
+ FB_COMPOSITOR_LIBS="-lGLESv2 -lEGL -lwayland-server -lxkbcommon" \
+ SIMPLE_EGL_CLIENT_CFLAGS="-DLINUX -DEGL_API_FB -DEGL_API_WL" \
+ CLIENT_CFLAGS="-DLINUX -DEGL_API_FB -DEGL_API_WL" \
+"