aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch17
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs_5.4.bb4
2 files changed, 20 insertions, 1 deletions
diff --git a/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch b/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch
new file mode 100644
index 0000000..2ac73ae
--- /dev/null
+++ b/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch
@@ -0,0 +1,17 @@
+This patch fixes a build error with kernel includes (>= 4.4) <stdint.h> must
+be explicitly included to get uintX_t types.
+
+Upstream-Status: Pending
+
+Index: imx-kobs-5.4/src/BootControlBlocks.h
+===================================================================
+--- imx-kobs-5.4.orig/src/BootControlBlocks.h
++++ imx-kobs-5.4/src/BootControlBlocks.h
+@@ -54,6 +54,7 @@
+ //! This structure holds the timing for the NAND. This data is used by
+ //! rom_nand_hal_GpmiSetNandTiming to setup the GPMI hardware registers.
+
++#include <stdint.h>
+ typedef struct _NAND_Timing {
+ uint8_t m_u8DataSetup;
+ uint8_t m_u8DataHold;
diff --git a/recipes-bsp/imx-kobs/imx-kobs_5.4.bb b/recipes-bsp/imx-kobs/imx-kobs_5.4.bb
index 5487160..1d33d40 100644
--- a/recipes-bsp/imx-kobs/imx-kobs_5.4.bb
+++ b/recipes-bsp/imx-kobs/imx-kobs_5.4.bb
@@ -5,7 +5,9 @@ SECTION = "base"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
-SRC_URI = "${FSL_MIRROR}/imx-kobs-${PV}.tar.gz"
+SRC_URI = "${FSL_MIRROR}/imx-kobs-${PV}.tar.gz \
+ file://fix-compile.patch \
+"
SRC_URI[md5sum] = "77467d834f858c2ec216841583e5f437"
SRC_URI[sha256sum] = "85171b46068ac47c42fedb8104167bf9afd33dd9527ed127e1ca2eb29d7a86bf"